I can't see other users logged in

Reported by mb74 on 2012-06-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Session Menu
Medium
Unassigned
indicator-session (Ubuntu)
Medium
Unassigned

Bug Description

I've installed 12.04 with home encryption for all users.
I've disabled the guest user.
I've added two other users B and C (A is me).
1) A logs in.
2) C logs in via the user switcher applet.
3) Switch back to A. In user switcher I can't see that C is logged in. Also "who" shows only my user.
4) B logs in via the user switcher applet.
5) Switch back to A. In user switcher I can't see that B and C are logged in. Also "who" shows only my user.
6) Switch to C. In user switcher I CAN see that A, B and C are logged in. Also "who" shows the correct list.
7) Switch to B. In user switcher I can see that A and B are logged in, but not C. Also "who" shows only users A and B.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: lightdm 1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu9
Architecture: amd64
Date: Wed Jun 6 10:28:10 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 LANGUAGE=de_AT:de
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

mb74 (mrb74) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the "who" issue is bug #870297

the lightdm greeter screen correctly list the connected users so the other issue seems to be an indicator one

affects: lightdm (Ubuntu) → indicator-session (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
tags: added: needs-design
Bilal Akhtar (bilalakhtar) wrote :

I guess (not sure) that this bug would be fixed when bug #870297 is squashed.

Or, more probably, the indicator's state is being "saved" when switching users and coming back.

Changed in indicator-session:
status: New → Confirmed
importance: Undecided → Medium
Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
tags: removed: needs-design
Amr Ibrahim (amribrahim1987) wrote :

It also affects the Guest user when switching back to it.

Charles Kerr (charlesk) wrote :

A refreshed Session Menu landed in 12.10. Is anyone still experiencing this bug after upgrading?

Charles Kerr (charlesk) wrote :

Following the steps listed in the Bug Description, my test in Q diverges at step 3 -- I'm seeing, in both the Session Menu and in "who", that user C is logged in.

Also: if "who" is /also/ not showing you user C, are there other clues that suggest user C actually is still logged in? Is it possible that C has been logged out somehow?

Changed in indicator-session:
status: Confirmed → Incomplete
Amr Ibrahim (amribrahim1987) wrote :

Is this bug going to be fixed in Ubuntu 12.04.x? I know that design-related bugs are hard to reach SRU. Can it be fixed for a point release, like 12.04.2?

Amr Ibrahim (amribrahim1987) wrote :

I also can't see the Guest session logged in from both the indicator and the lightdm greeter screen. Ubuntu 12.04.

Changed in indicator-session:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers