Show desktop plug-in fades windows out and ignores movement and movement direction settings completely once unityshell is enabled

Reported by MC Return on 2012-05-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Compiz
Undecided
MC Return
Unity
Low
MC Return
6.0
Low
MC Return
compiz (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Test Case]
Make sure the Fade to Desktop plugin cannot be enabled when Unity is enabled.

[Regression Potential]
No regression potential.

Original description:

It fades the windows out/in to hide/show the desktop like the "Fade to Desktop" plug-in should do instead of moving the windows out of view like it did in the past.

This is happening because this plug-in and its settings are ignored once unityshell runs and Unity uses its own code to fade to the desktop (unity/plugins/unityshell/src/UnityShowdesktopHandler.cpp/.h).

MC Return (mc-return) wrote :

It seems that Unity is causing that bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-07-24
Changed in compiz:
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-design
MC Return (mc-return) wrote :

om26er, why is this bug report being marked incomplete by you and why does fixing a bug need design ?

John Lea (johnlea) on 2012-07-26
Changed in compiz (Ubuntu):
status: Incomplete → Opinion
Changed in unity:
status: Incomplete → Opinion
Changed in compiz:
status: Incomplete → Opinion
MC Return (mc-return) on 2012-10-08
description: updated
summary: Show desktop plug-in fades windows out and ignores movement and movement
- direction settings completely
+ direction settings completely once unityshell is enabled
MC Return (mc-return) wrote :

This is no opinion, but a bug:

How to reproduce:
1. Install all Compiz plug-ins and CCSM via package-manager.
2. Open CCSM, enable "Show Desktop".
3. Press "Super+D" to activate it.

What you would expect:
Windows should move out of view to the corners of your screen

What actually happens:
Unity still uses its own code to show the desktop and your settings in the "Show Desktop" plug-in are ignored

Changed in compiz:
status: Opinion → In Progress
Changed in unity:
status: Opinion → In Progress
Changed in compiz:
assignee: nobody → MC Return (mc-return)
Changed in unity:
assignee: nobody → MC Return (mc-return)
John Lea (johnlea) wrote :

@mc-return; I'm changing the status of this bug back to Opinion because it is a design change. However if you could attach a screencast of the requested animation, we will review it against our existing animation and make a decision on whether or not this change should land.

Sorry about this, but it is really a design change, not a bug fix, christian giordano needs to signoff all animation changes.

Changed in compiz:
status: In Progress → Opinion
Changed in unity:
status: In Progress → Opinion
John Lea (johnlea) wrote :

@mc-return; also we will reply promptly as soon as a screencast is uploaded. Many thanks!

I think what MC Return is trying to say is that unity overrides the user-specified behaviour when either one of these plugins is loaded and either it shouldn't, or unity should be marked as conflicting with those two.

On a technical level, not overriding the behaviour is harder than it sounds but patches welcome.

John Lea <email address hidden> wrote:

>@mc-return; I'm changing the status of this bug back to Opinion because
>it is a design change. However if you could attach a screencast of the
>requested animation, we will review it against our existing animation
>and make a decision on whether or not this change should land.
>
>Sorry about this, but it is really a design change, not a bug fix,
>christian giordano needs to signoff all animation changes.
>
>** Changed in: compiz
> Status: In Progress => Opinion
>
>** Changed in: unity
> Status: In Progress => Opinion
>
>--
>You received this bug notification because you are a member of Compiz
>Maintainers, which is subscribed to Compiz.
>Matching subscriptions: Compiz bugs
>https://bugs.launchpad.net/bugs/1006434
>
>Title:
> Show desktop plug-in fades windows out and ignores movement and
> movement direction settings completely once unityshell is enabled
>
>Status in Ayatana Design:
> New
>Status in Compiz:
> Opinion
>Status in Unity:
> Opinion
>Status in “compiz” package in Ubuntu:
> Opinion
>
>Bug description:
> It fades the windows out/in to hide/show the desktop like the "Fade to
> Desktop" plug-in should do instead of moving the windows out of view
> like it did in the past.
>
> This is happening because this plug-in and its settings are ignored
> once unityshell runs and Unity uses its own code to fade to the
> desktop (unity/plugins/unityshell/src/UnityShowdesktopHandler.cpp/.h).
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ayatana-design/+bug/1006434/+subscriptions

MC Return (mc-return) wrote :

@johnlea: Please note that I do not want to change anything here regarding the Unity showdesktop behaviour, but as Sam said just prevent this bug from happening.
Please also see bug 1063171.

Fact is that both Compiz plug-ins do not work/produce undefined behavior and bugs once activated in CCSM if Unity runs and this should and can easily be fixed.
With the branch linked here, the unityshell plug-in informs CCSM that it already provides the feature showdesktop and thus prevents activating any of those 2 plug-ins (Show Desktop/Fade to Desktop) as long as Unity runs.

John Lea (johnlea) wrote :

@mc-return; ok, no worries, I though you were requesting a change to the default show desktop animation ;-)

Changed in compiz:
status: Opinion → Confirmed
Changed in unity:
status: Opinion → Confirmed
Changed in compiz (Ubuntu):
status: Opinion → Confirmed
MC Return (mc-return) wrote :

@johnlea: Please note that I do not want to change anything here regarding the Unity showdesktop behaviour, but as Sam said just prevent this bug from happening.
Please also see bug 1063171.

Fact is that both Compiz plug-ins do not work/produce undefined behavior and bugs once activated in CCSM if Unity runs and this should and can easily be fixed.
With the branch linked here, the unityshell plug-in informs CCSM that it already provides the feature showdesktop and thus prevents activating any of those 2 plug-ins (Show Desktop/Fade to Desktop) as long as Unity runs.

MC Return (mc-return) wrote :

Sorry for double-posting above ;)

Here the requested screencasts.

The first one shows that the Show Desktop plug-in does not work as expected if Unity runs and windows are faded out, although specified otherwise.

MC Return (mc-return) wrote :

Without Unity it works as expected and the windows slide out of view.

@Sam

This looks like what his branch is doing. When you try to set Show Desktop plugin to active with his branch is gives you an option to Not enable Show Desktop plugin or Disable Unityshell plugin. So this branch seems to raise a conflict warning, which seems correct.

Changed in unity:
status: Confirmed → In Progress
milestone: none → 7.0.0
Changed in unity:
status: In Progress → Fix Committed
Changed in compiz:
status: Confirmed → Won't Fix
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Fix Committed → In Progress
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
status: In Progress → Fix Committed
description: updated

Hello MC, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Chris Halse Rogers (raof) wrote :

Hello MC, or anyone else affected,

Accepted unity into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/6.10.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu2

---------------
unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 18:00:00 +0100

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.10.0-0ubuntu3

---------------
unity (6.10.0-0ubuntu3) raring; urgency=low

  * Upload to raring

unity (6.10.0-0ubuntu2) quantal-proposed; urgency=low

  * Cherry-picked from upstream:
    - [SRU Regression] Launcher icon corruption while rearranging
      (LP: #1071813)

unity (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Gap between the dash gradient and the panel one (LP: #1062375)
    - [regression] Dash closes if the onscreen keyboard is outside of
      Dash' geometry (LP: #1058705)
    - Dash - Category expander arrow is in expanded mode no matter if
      category is actually expanded (LP: #1053047)
    - Unity panel does not show the kate menus in the correct order
      (LP: #1062283)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a() from
      g_object_unref() from _g_file_attribute_value_clear() from ... from
      query_info_async_cb() [libgvfsdbus.so] (LP: #1061510)
    - dash's music album previews: can't drag the scrollbar (LP: #1056995)
    - Small chunks of the panel shadow appear individually (and very dark)
      (LP: #1057528)
    - compiz crashed with SIGSEGV on Unity "Unmount" (LP: #1055812)
    - [regression] Dash - 'More suggestions' icons in App Lens are too
      large (LP: #1052513)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes (LP: #772986)
    - Changes the swapping order of the detail mode. Now the currently
      active window gets moved to the end, instead of getting swapped
      with the last used window (LP: #1061229)
    - Fixes GetRegion tex coord maths (LP: #1058391)
    - Fixed fade-in behavior of Unity's showdesktop function (LP: #1063249)
    - Added <feature>showdesktop</feature> to unityshell.xml.in, because
      the feature showdesktop is provided by unityshell. (LP: #1006429)
      (LP: #1006434) (LP: #1063171)
    - Make HudLauncherIcon::ubus_manager_ "un-static" (LP: #1048274)
    - Fix reference counting problem which leads to memory leaks and a
      crash in MT grab handles (LP: #1046201)
    - Ensure categories with non-personal results can show up before empty
      categories with personal results (LP: #1067327)
    - fix a backup error (LP: #1066646)

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream:
    - Reverted the switch from boost to std which was part of the fix for
      LP: #1046201. The crash is still fixed without this change, so it was
      actually unneeded
 -- Didier Roche <email address hidden> Fri, 09 Nov 2012 08:06:47 +0100

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers