Window management - When a monitor is disconnected, the windows do not move to the remaining monitor and the Launcher pips do not update

Reported by John Lea on 2012-05-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Compiz
High
Brandon Schaefer
0.9.8
Medium
Unassigned
Compiz Core
Medium
Unassigned
compiz (Ubuntu)
High
Brandon Schaefer

Bug Description

When a monitor is disconnected in a multi-monitor environment, the Launcher pips do not update

Steps to reproduce, example 1:

1. Open two GEdit window on one monitor (using a computer with two monitors)

2. Disconnect the monitor the two windows are on, and press "Detect Displays" in 'Settings/Displays'

Current incorrect behaviour: The Launcher on the remaining monitor continues to display the hollow triangle next to the GEdit icon, and the two windows are not moved on to the remaining monitor.

What should happen: The Launcher on the remaining monitor should display two pips next to the GEdit icon, and the windows should be moved on to the remaining monitor.

Steps to reproduce, example 2:

1. Open one GEdit window on each monitor (using a computer with two monitors)

2. Disconnect one of the two monitors, and press "Detect Displays" in 'Settings/Displays'

Current incorrect behaviour: The Launcher on the remaining monitor continues to display only one pip next to the GEdit icon. Clicking on the GEdit icon does not spread the window that was one the other monitor, it is as if it has disappeared! (but it has incorrectly been moved to a different workspace).

What should happen: The Launcher on the remaining monitor should display two pips next to the GEdit icon, and the window on the disconnected monitor should be moved on to the remaining monitor.

Related branches

lp:~brandontschaefer/compiz/lp1002246_fix
Rejected for merging into lp:compiz/0.9.9
Daniel van Vugt: Needs Information on 2012-12-12
PS Jenkins bot: Approve (continuous-integration) on 2012-12-12
lp:~brandontschaefer/compiz/lp.102246-remove-if-no-struts
Merged into lp:compiz/0.9.9 at revision 3532
Stephen M. Webb: Approve on 2012-12-27
Sam Spilsbury: Approve on 2012-12-20
PS Jenkins bot: Approve (continuous-integration) on 2012-12-19
John Lea (johnlea) on 2012-05-21
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
summary: - multimonitor, window management - When a monitor is disconnected, the
- Launcher pips do not update
+ multimonitor, window management - When one monitor is disconnected in
+ multi-monitor environment, the windows to not move to the remaining
+ monitor and the Launcher pips do not update
tags: added: multimonitor

I believe this is a duplicate and/or fixed upstream already anyway. Just can't find the other bug right now.

Changed in compiz:
status: New → Confirmed
milestone: none → 0.9.8.0

See also: bug 804036, which is different but equally annoying.

summary: - multimonitor, window management - When one monitor is disconnected in
- multi-monitor environment, the windows to not move to the remaining
+ When a monitor is disconnected, the windows do not move to the remaining
monitor and the Launcher pips do not update
Tim Penhey (thumper) on 2012-06-11
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
importance: Undecided → High
Changed in compiz:
importance: Undecided → High
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
John Lea (johnlea) on 2012-08-23
summary: - When a monitor is disconnected, the windows do not move to the remaining
- monitor and the Launcher pips do not update
+ Window management - When a monitor is disconnected, the windows do not
+ move to the remaining monitor and the Launcher pips do not update
Omer Akram (om26er) on 2012-08-23
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
no longer affects: unity (Ubuntu)
Changed in unity:
status: Triaged → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
John Lea (johnlea) on 2012-10-10
Changed in compiz:
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Undecided → High
Stephen M. Webb (bregma) on 2012-12-06
Changed in compiz:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Changed in compiz:
status: Triaged → In Progress
Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
John Lea (johnlea) on 2012-12-12
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Changed in compiz-core:
milestone: none → 0.9.7.14
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.01.14-0ubuntu1

---------------
compiz (1:0.9.9~daily13.01.14-0ubuntu1) raring; urgency=low

  [ sampo555 ]
  * compiz crashed with SIGSEGV in DodgeAnim::applyDodgeTransform() (LP:
    #1048840)
  * compiz crashing if window un-/minimize animation is "Random" (LP:
    #1098185)

  [ Daniel van Vugt ]
  * Several leaks in new GLProgram from compileProgram() from
    GLScreen::getProgram() from GLWindowAutoProgram::getProgram() (LP:
    #1097644)

  [ Sam Spilsbury ]
  * Several leaks in ccsIntegratedSettingListAppend() ... from
    ccsGNOMEIntegrationBackendGetIntegratedSetting() from readSetting
    (gsettings.c:375) (LP: #1097661)

  [ MC Return ]
  * Thumbnail Window Previews: Flickering of background/glow and window
    title text (LP: #1098758)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3561
 -- Automatic PS uploader <email address hidden> Mon, 14 Jan 2013 04:03:09 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints