Awn

Launcher/Taskmanager shows an ugly, useless green plus sign, which cannot be removed

Bug #990774 reported by Eduar Arley Cardona on 2012-04-28
176
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Awn
Medium
Unassigned

Bug Description

Ubuntu 12.04 AWN 0.4.1 from Ubuntu Software Center. All updates from there. Using gnome-panel. I don't use Unity.

When I add Launcher/Taskmanager to AWN, I get all icons work OK, but I also get a green plus icon, with no hint. Left click on it does nothing. Right click on it does nothing. Double clic on it does nothing. If I drag and drop an icon to Launcher, green plus icon goes away, but in next reboot, it comes back again. It also goes away if I drag an icon to reorder, but in next reboot it reappear.

See attachment for details. Sorry for my bad language, I'm latin.

Tags: awn Edit Tag help
Eduar Arley Cardona (eduar47) wrote :
description: updated
Bruce (brunces) wrote :

Same thing here. I can reproduce it at any time, just loading the launcher. Please, fix it. AWN is the best dock ever. Cheers. :)

Changed in awn:
status: New → Confirmed
Not Rob Loach (robloach-gmail) wrote :

Confirmed... Xubuntu 12.04.

Ashley Dean (redspud) wrote :

Same thing on Kubuntu 12.04 64bit. AWN 0.4.1 from the main ubuntu repository.

Ham Barlow (hamilton-barlow) wrote :

It appears to be associated with the simple-launcher applet which uses the same green plus icon. If you add the simple-launcher applet to your dock, then add a launcher to it, the "extra" green plus will disappear, but the simple-launcher icon remains.

Perhaps the Launcher/Task Manager applet shares some of the same code, and in the lastest version of AWN, the plus is either accidentally showing or is there by design -- perhaps so users know they can add new Launchers/Tasks?

Either way, I don't like it, and would prefer it be gone as in previous versions of AWN.

Wagner Volanin (volanin) wrote :

Workaround: It is possible to remove the plus sign by dragging a launcher that is already in the panel over it. The green plus sign will disappear and the launcher will not be affected. But as soon as you restart the panel, the green sign is back again.

arejay (robert-jameson) wrote :

I'm also seeing this bug on ubuntu 12.04 with awn 0.4.1~bzr830-2ubuntu1

linfidel (linfidel) wrote :

I have this thing on my new install of 12.04, both with and without Unity. It's ugly and useless, not to mention BIG. I'm tempted to use Cairo Dock until it's fixed unless I find a way to hide it.

linfidel (linfidel) wrote :

One additional comment... Making any change to the icons drop down in the task manager settings makes this disappear until the next login. All 4 choices will make it disappear, though, and I haven't found anything else other than removing the task manager/launcher applet that gets rid of it.

Akoi Meexx (akoimeexx) wrote :

Affects me as well:
~ $ avant-window-navigator --version
Avant Window Navigator 0.4.1

~ $ uname -a
Linux lenovo-thinkpad 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

setcho (setcho) wrote :

I'm on Linux Mint 13 Cinnamon and this bug also affects me.

atarixle (atarixle) wrote :

Same here (Linux Mint 13 MATE 64 Bit)

Rob Peters (makitso) wrote :

As much as I would like to see this bug fixed I suspect it will not. There has been little maintenance on AWN for several years. I have switched to the CAIRO dock -- which gets the job done but is not AWN.

xiota (xiota) wrote :

The unwanted plus icon IS (was) present on my computer running Ubuntu 12.04 with AWN 0.4.1. The unwanted plus icon is NOT present on my backup computer running Debian testing with AWN 0.4.1 installed from the unstable repository.

I think I've gotten rid of the unwanted icon on my Ubuntu computer. (Yay.) What did I do? ...

apt-get build-dep avant-window-navigator
apt-get -b source avant-window-navigator
sudo dpkg -i avant*.deb

That makes no sense. How does simply recompiling fix the problem? ... Well...

On Debian, AWN stores its settings in '.gconf', but on Ubuntu, AWN stores its settings in *.ini files at ~/.config/desktop-agnostic/

The difference in how AWN stores its settings is probably set by flags (or whatever) during compilation because the source and patch files downloaded by apt-get on both machines are essentially identical. There's probably a defect in the code that loads the *.ini files. Simply recompiling does not set whatever special compile-time flags and creates a set of AWN packages that stores settings in '.gconf'. Having '.gconf' around just for AWN isn't 'elegant', but it's way better than that ugly plus icon.

I hope the above info is useful. Good luck, everyone.

xiota (xiota) wrote :

Oops... correction...

apt-get build-dep avant-window-navigator
apt-get -b source avant-window-navigator
sudo dpkg -i *.deb

Pablo Lillia (gorlok) wrote :

I had this problem only on one fresh installed desktop with 12.04. This issue was not present on two other desktops upgraded to 12.04.

I can confirm that this workaround from @xiota solved it for me:

apt-get build-dep avant-window-navigator
apt-get -b source avant-window-navigator
sudo dpkg -i *.deb

Thanks for the tip :)

jpxsat (jpxsat) wrote :

Confirming the bug.
I can't work on the fix by @xiota.
First command throws an error in my console: "can't find the packages..."
Is there any further step to make the fix working?

Druciferre (drewchapin) wrote :

I too can confirm this bug, and I can confirm that xiota's solution of recompiling and re-building the package is a work-around. Please note though that the command apt-get -b source avant-window-navigator does create multiple .deb packages in the working directory. So, I recommend you start with an empty working directory so you don't accidentally install any .deb packages you might in the working directory.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

inkubator (alen-voloder) wrote :

Confirmed on Xubuntu 12.04 64bit (Fresh install).

AWN from the main Ubuntu repository:
$ avant-window-navigator --version
Avant Window Navigator 0.4.1

I also confirm that xiota's solution is working for me.

xiota (xiota) wrote :

Glad the workaround I found is working for others. A few thoughts...

1. It is a good idea to work in a new directory...

     mkdir /tmp/avant-new
     cd /tmp/avant-new

when recompiling...

     apt-get build-dep avant-window-navigator
     apt-get -b source avant-window-navigator
     sudo dpkg -i *.deb

2. If the 'apt-get' commands don't work (eg, can't find the packages), the source repositories are probably missing from /etc/apt/sources.list ... a google search for "deb-src" might help.

KAtanasov (katanasov) wrote :

There shouldn't be any need for building. One needs to install "libdesktop-agnostic-cfg-gconf", which should make awn to use gconf, and the problem should be solved.

Regards

tpjk (tpjk) wrote :

katanasov's suggestion works for me. I am running Linux Mint 13 64 Bit with MATE.

Regular User (dot.ru) wrote :

katanasov's suggestion wrought a lot of instability to some of my unity desktop software. I don't recommend it.

Regular User (dot.ru) wrote :

@xiota: for some reason compiling errors out on my ubuntu 12.10 64bits, something having to do with this: awn-panel-dispatcher.vala:57.36-57.47: error: GVariant deserialization of type `DBus.BusName' is not supported

Regular User (dot.ru) wrote :

After being unable to actually compile the awn package as described above I just installed the one on the repository and the plus sign never appears. It seems that just installing all the dependencies needed to compile awn and then installing the deb package would do the trick in removing the plus sign.

PS: DO NOT install the libagnostic package suggested above, it introduced _serious_ unstabilities on my system (on my session, especifically) that did not go away uninstalling the package, I had to reinstall ubuntu.

Wagner Volanin (volanin) wrote :

Katanasov's suggestion also works for me.

Curiously, despite Rpgmaker warnings, he later says that "just installing all the dependencies needed to compile awn and then installing the deb package would do the trick"... but this only happens because the very package mentioned by Katanasov is one of the dependencies.

No instabilities here, using Precise 12.04 32-bits.

Povilas Kanapickas (p12) wrote :

Could you check whether this bug is still present in the testing packages in this PPA: https://launchpad.net/~p12/+archive/awn ?

Thanks!

Changed in awn:
importance: Undecided → High
importance: High → Medium
Povilas Kanapickas (p12) on 2013-11-05
Changed in awn:
status: Confirmed → Incomplete
Mitch Claborn (mitch-news) wrote :

I installed the version in the PPA (Avant Window Navigator 0.4.1~git20131105) and it did not fix the problem for me.

Povilas Kanapickas (p12) on 2013-11-18
Changed in awn:
status: Incomplete → Confirmed
Povilas Kanapickas (p12) wrote :

I can't reproduce this bug. Could you attach your ~/.config/desktop-agnostic/avant-window-navigator.ini file?

Also, could you check which applet causes the bug by removing them one by one?

Mitch Claborn (mitch-news) wrote :

It appears to be the Launcher/Taskmanager apple that causes the problem.

I work around it by going to the Task Manager settings, then turning the "Group common windows" box on. That makes the plus sign disapper. (I then turn this setting back off, which is how I want it.)

Povilas Kanapickas (p12) wrote :

Still can't reproduce. Could you attach the input of the following command?

gconftool-2 --dump /apps/awn-applet-taskmanager

Povilas Kanapickas (p12) wrote :

Typo: "input" -> "output"

Povilas Kanapickas (p12) wrote :

Could you also install check whether you have libdesktop-agnostic-cfg-gconf package installed and libdesktop-agnostic-cfg-keyfile not installed?

Mitch Claborn (mitch-news) wrote :

dpkg --get-selections | grep agnostic

libdesktop-agnostic-cfg-keyfile install
libdesktop-agnostic-data install
libdesktop-agnostic-fdo-gnome install
libdesktop-agnostic-vfs-gio install
libdesktop-agnostic0 install
python-desktop-agnostic install

moonbeam (rcryderman) wrote :

Glad to see someone working on awn again. Miss having time to working it but maybe someday I will have time to contribute again.

Anyway, having written the buggy code in question, I can confirm the bug exists and it is race condition where the visibility of that icon gets reset to visible after the code to set it invisible is set. When I get a chance to sit down at a real computer and try and pinpoint the code

Povilas Kanapickas (p12) wrote :

Ugh, as far as I remember this bug is caused by libdesktop-agnostic-cfg-keyfile. A please remove it and install libdesktop-agnostic-cfg-gconf, this should fix the issue (note, you will lose your applet settings).

In fact, a fixed package has been already uploaded almost a week ago, but failed to build due to unrelated reasons, an important fact that I forgot.

Povilas Kanapickas (p12) wrote :

Please excuse me for the typos :)

Povilas Kanapickas (p12) wrote :

@moonbeam: Some users claim that removing libdesktop-agnostic-cfg-keyfile fixes the problem. Is it related?

moonbeam (rcryderman) wrote :

@povilas I think is just happens to be easier to trigger when using agnostic. I have a system at home that has the issue. Will have a look at what backend it uses when I have a chance. I _believe_ it is using gconf.

Mitch Claborn (mitch-news) wrote :

Switching to libdesktop-agnostic-cfg-gconf fixed this for me.

Povilas Kanapickas (p12) on 2013-11-22
Changed in awn:
status: Confirmed → In Progress
juppy (richard-a-jupp) wrote :

Switching to libdesktop-agnostic-cfg-gconf fixed this for me too - LinuxMint13 LTS w/ xfce, no instability. Some applets work better e.g. Bandwidth Monitor 'Interfaces' tab is populated. Text on Hardware Sensor applet is bold, bit too big, looking for fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers