Avant Window Navigator

awn-settings crashed with AttributeError in register_applet()

Reported by ppp1pp1p1 on 2010-04-01
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Awn
Low
Unassigned
avant-window-navigator (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: avant-window-navigator

a message with "Sorry, Awn Settings closed unexpetedly" appears after trying to install a clock app (http://bit.ly/cAICxZ) without closing or freezing the settings-window (so I can go on operating with the settings-window / changing settings)

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: awn-settings 0.4.0~rc1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 1 11:13:11 2010
ExecutablePath: /usr/bin/awn-settings
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/awn-settings
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/awn-settings']
SourcePackage: avant-window-navigator
Title: awn-settings crashed with AttributeError in register_applet()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

ppp1pp1p1 (ppp1pp1p1) wrote :
tags: removed: need-duplicate-check
Julien Lavergne (gilir) wrote :

Thanks for your bug report. Forwarding upstream.

visibility: private → public
Changed in avant-window-navigator (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Michal Hruby (mhr3) on 2010-04-10
Changed in awn:
status: New → Confirmed
importance: Undecided → Low
Gabor Karsay (gabor-karsay) wrote :

Attached patch fixes this bug and makes it possible to install 3rd party applets. However, there are still some issues with them as reported in bug #651592.

tags: added: patch
Povilas Kanapickas (p12) wrote :

Could you check whether this bug is still present in the testing packages in this PPA: https://launchpad.net/~p12/+archive/awn ?

Thanks!

Povilas Kanapickas (p12) wrote :

Closing as no response was received. Feel free to reopen the bug if it is still reproducible.

Changed in awn:
status: Confirmed → Invalid
Povilas Kanapickas (p12) wrote :

The patch was applied regardless, as this looks like an obvious typo.

Changed in awn:
status: Invalid → Fix Released
Changed in avant-window-navigator (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers