Avant Window Navigator

Unable to click to the sides of AWN

Reported by Hugo Osvaldo Barrera on 2010-03-28
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Awn
Undecided
Unassigned
Xfwm4
Confirmed
Undecided
Unassigned
Debian
New
Undecided
Unassigned
Fedora
New
Undecided
Unassigned

Bug Description

I'm using fedora amd64 with compiz (latest stable)

I have AWN configured NOT to autohide, at the bottom of my screen.

My issue is as follow:
Supose AWN has a current width of 50% of my screen, and about 64px hieght.
If I try to click on another window, specifically: on the portion that is in that 25% to the left OR right of AWN, and on the lower 64px region of the screen, the click does nothing, it gets ignored.

This happens with all clicks (left, right, middle).

I've attached an image, since re-reading this made me realize it's quite hard to understand.
Blue part is AWN. Green part is clickable. Red parts are UN-clickable.

Michal Hruby (mhr3) wrote :

What Awn version is this? Graphics card/driver you use? Does your X server support the Shape extension?

Changed in awn:
status: New → Incomplete

Avant Window Navigator 0.3.2.1

Video Card: GeForce 8800GTX
Video Driver: nvidia 190.53 (the propietary one)

I'm not sure what shape extension is, or how to know if my server supports it.
A quick google search led me to belive this may help; if it doesn't, please tell me how to determine if it's supported:

$ xdpyinfo -ext all
[...cropped...]
number of extensions: 28
[...cropped...]
    SHAPE
[...cropped...]
SHAPE version 1.1 opcode: 141, base event: 98
$

A bit more google reading, helped me discover window shaping IS supported. If I run xeyes, I can click though between the eyes and the click "reaches" the window behind them. :)

Michal Hruby (mhr3) wrote :

Well, that is weird, obviously it's working for 99% of our users, otherwise someone would notice in the past year when 0.3.2 was released.

The only thing I can recommend is trying our latest 0.4.0 version.

Ok, I'll give it a try next week and keep you posted. I'll be away from home till then.

SoapSeller (soapseller) wrote :

I have a very similar problem.

It's actually a little bit worse, since the non-clickable area is extending for another ~50% above awn.
(And so its covering the bottom part of virtual every application I run).

I'm pretty sure that is something new, since I'm using awn for more then a year now.

There is something I've noticed that might help to shade some light on the issue,
I'm using compiz and have the "Preview" option on - when I'm hovering with the mouse above the icons I a thumbnail of the running application appears.
Clicking in the non-clickable area above the awn icons does nothing, but hovering activating the Preview feature of the "right" application...

Michal Hruby (mhr3) wrote :

For people experiencing this issue, please note your distro, awn, gtk and cairo versions.

SoapSeller (soapseller) wrote :

I know I forgot something...

Arch Linux 64bit
awn 0.3.2.1
gtk 2.18.9
cairo 1.8.10

and as I've mentioned before, I'm using Compiz as my desktop env(no gnome/kde/xfce etc').

Wayne Rowcliffe (war1025) wrote :

Debian 64bit Squeeze

libgtk2.0-0 2.18.9-2
avant-window-navigator 0.3.2.1-6
libcairo2 1.8.10-3

Wayne Rowcliffe (war1025) wrote :

I built awn 0.4 and it works so I think it might be something to do with awn 0.3.2

I'm also using compiz preview, like some have said.
I haven't had a chance to try disabling it, since I'm away from home for about a week.
Will post back as soon as I know something.

I have same problem on Debian SID, amd64;
Xorg 7.5;
Open ATI driver 6.12.192;
Cairo 1.8.10
awn 0.3.2.1

I not able to click in some areas after upgrade "libgtk2.0-0 libgtk2.0-bin gtk2-engines-pixbuf libgail18" to version 2.18.9-1.
I tried to upgrade same packages from experimental, version 2.19.7-3, so che click have no problem. It come back to work.
After upgrade in experimental to version 2.20.0-1 the problem returns.

Now I freeze them to 2.19.7-3 version for the right working of click.

The problem isn't related to AWN only.
The click doesn't work through any transparent area on the screen, like notification area (notify-osd).

Regards

Michal Hruby (mhr3) wrote :

It would greatly help us if someone affected could try this with the latest gtk, but without http://git.gnome.org/browse/gtk+/commit/?id=996541d096d4d59e9baa384e5d5359a10567433e to determine if this was indeed the commit that broke things.

Michal Hruby (mhr3) wrote :

Nevermind, notify-osd already confirmed that this indeed is the commit that breaks it. (https://bugs.launchpad.net/notify-osd/+bug/546650)

Michal Hruby (mhr3) wrote :

This is fixed now in GTK+ (http://git.gnome.org/browse/gtk+/commit/?id=0efb24f589a74c4a4e78a1803d6e7205be9c1984), and should be released as a bugfix soon. Still, we recommend using Awn 0.4.0, which doesn't exhibit this issue even without the GTK+ fix.

Changed in awn:
status: Incomplete → Invalid
Philip P. (nucrap) wrote :

This bug still affects me. I'm using ArchLinux and my system is up to date.
I also attached an image to illustrate the behaviour and it looks lke the very same bug.

I'm using AWN 0.4.0 as you've recommended and GTK 1.2.10.

Philip P. (nucrap) on 2012-08-03
Changed in awn:
status: Invalid → Confirmed
Philip P. (nucrap) wrote :

OK, I figured out that it's related to xfwm4 - the default window manager of xfce 4.10.

When I use compiz as window manager, there's no problem at all.

Xodetaetl (ovocean) wrote :

I'm having this annoying bug on
Xfce 12.10
Intellihide behavior

Steps to reproduce the bug :

Under Xfce, set AWN to be oriented left, hiding with "intellihide",
put a desktop icon on the upper or lower left corner,
open any window and maximize it (awn will hide),
close the window,
try to select the icon on the desktop.

Now, as far as I can see, there is a total lack of developers for this neat application since 2010-11 and the list of open bugs is already huge. :(

Xodetaetl (ovocean) on 2013-02-03
Changed in xfwm4:
status: New → Confirmed
Xodetaetl (ovocean) wrote :

I'm willing to pay 10.00 bucks for this bug to be fixed.
I've opened a bounty at FreedomSponsors (http://www.freedomsponsors.org/core/issue/151/unable-to-click-to-the-sides-of-awn).
Once someone solves it, just create a FreedomSponsors account and mark it as resolved (you'll need a Paypal account to receive the payment).
I (and others who pledged) will then check it out and will gladly pay up!

If anyone else would like to throw in a few bucks to elevate the priority on this issue, go pledge !

Povilas Kanapickas (p12) wrote :

Could you check whether this bug is still present in the testing packages in this PPA: https://launchpad.net/~p12/+archive/awn ?

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments