Avant Window Navigator

Nautilus launcher not working

Reported by 6205 on 2009-11-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Awn
Low
Michal Hruby

Bug Description

AWN version - current trunk 0.3.9.1+

If i create custom launcher for Nautilus file manager, this laucher is simply not working. There is no reaction from AWN.

Normally if you run in terminal command "nautilus" it's working OK but not in AWN launcher and same is for launcher with command "nautilus --no-desktop --browser %U" which is used in standard GNOME menu Applications > System > File browser.

moonbeam (rcryderman) wrote :

Please attach the desktop file that is causing the issue.

It's not a desktop file, i have created that launcher through AWN, like any other custom launchers

Michal Hruby (mhr3) wrote :

Creating launcher via awn-settings actually creates desktop file in ~/.config/awn/launchers...

Michal Hruby (mhr3) on 2009-11-26
Changed in awn:
status: New → Incomplete

Currently is my folder ~/.config/awn/launchers empty (attached printscreen) There were launchers only for Brasero and Terminal. I deleted them for testing of behavior but it has no effect on AWN.

When i have dragged launcher for Nautilus from menu to dock he have appeared only in AWN launchers window and also they are not using localized strings, in my case slovak language, but all launcher names on mouse over are in english, even if they are in AWN window in slovak. (look at Banshee Media Player)

Looks like this entire launcher dragging + desktop file creation is not working properly. But after some attemps was Nautilus desktop file finaly created. Where is rest of launchers or configuration stored i don't know..

Now this is getting interesting..

Dragged launchers from menu are not localized and also they don't have desktop file in .config/awn/launchers (Before.png)

But when i manually rename that launcher to slovak or whatever, after that will be also desktop file created (After.png)

Michal Hruby (mhr3) wrote :

If you use a desktop file from the menu, there's no need to copy it to the home folder, only if you make changes to it... as you noticed. Anyway we have no problems to use the desktop file you posted from Awn, so we'll investigate further. Are you using autostart of Awn? Could you try to quit it, run it from terminal and then use the nautilus launcher?

And sorry for offtopic, but you have a really neat theme colors, could you export the theme and post it somewhere? It'd nicely complement our "Dark theme". :)

This is really strange, today it is that Nautilus launcher working without a problems for the first time.. I am unable to make it not working again :/ but i swear it was not working in past days and i was using instead file browser launcher applet.. Now i look like idiot :)

It still working. You can propably close this bug report and sorry for spamming..

>> off-topic - i have also tweaked default Dark color scheme :) inspiration in both was Docky.

Btw. it is possible to modify color of that square around selected active app? (selected.png)
I would like to disable it or make it fully transparent or something, and have only glowing dot..

Michal Hruby (mhr3) wrote :

It is possible that this got fixed in the PPA update a day ago, so marking as Fix committed.

> Btw. it is possible to modify color of that square around selected active app? (selected.png)

It's on my todo, along with dot color.

Changed in awn:
status: Incomplete → Fix Committed
milestone: none → 0.4.0

Btw. it is possible to modify color of that square around selected active app?

> It's on my todo, along with dot color.

Sounds great :) You could add options like "Fill color" and "Outline color"

Tomas Cohen (tomas.adrian) wrote :

This bug is NOT solved, I'm having this issue as well running the latest AWN from PPA (0.3.9.1 bzr 1865-1.9.10). I created a launcher for nautilus with the following command: nautilus --no-desktop --browser %U. It's not working.

haytjes (h4writer) wrote :

Indeed isn't fixed.
Some more information about the bug:

- it happens when using "nautilus", "nautilus --no-desktop", "nautilus --browser" or "nautilus --no-desktop --browser" as command.
- After you opened "nautilus" for the first time (through Alt-F2) the launcher suddenly works until computer restart.

moonbeam (rcryderman) on 2009-12-22
Changed in awn:
status: Fix Committed → Confirmed
assignee: nobody → moonbeam (rcryderman)
Sam Illingworth (mazz0) wrote :

I have the same problem using launching Nautilus from a menu (any of the menu applets) - nothing happens. This is only when AWN was auto-started, stopping AWN and starting it manually (even with the auto-start option) fixes it. Something to do with the order things start up in presumably? Oh, but selecting a Place from a Places menu works.

More details (maybe) in https://bugs.launchpad.net/bugs/501303, which has been marked as a duplicate of this.

TLArevo (tla-revo) wrote :

I think I've solved the problem (it works for me) Create a custom launcher and as the command which should run i gave the following command .........
"nautilus --no-desktop computer:" (without the quotes, be careful about the spaces and dashes)

lotus49 (lotus-49) wrote :

Thanks TLArevo, that did it for me.

I also tried creating a launcher as I normally would (ie launch app manually, right click -> Add as launcher) for Nautilus and then editing it. The bit that made the difference was the addition of the " computer:".

The launcher now works perfectly.

Michal Hruby (mhr3) on 2010-04-14
Changed in awn:
milestone: 0.4.0 → 0.4.2
Michal Hruby (mhr3) on 2010-04-21
Changed in awn:
assignee: moonbeam (rcryderman) → Michal Hruby (mhr3)
importance: Undecided → Low
status: Confirmed → Fix Committed
atarixle (atarixle) wrote :

so how can I open my personal folder with that "computer:" thingy? I'm used to open my personal folder with a click on the first icon in the dock ... computer:///home/user/ didn't work, computer:/home/user/ also didn't ... even "/home/user/" (without "computer:") didn't.

atarixle (atarixle) wrote :

I'm so stupid ... instead of checking out the nautilus wiki BEFORE I post that question:
nautilus --no-desktop --browser file:///home/user
works perfectly

To open the personal folder use this command: "nautilus --no-desktop ." [a "dot" at end of string]

Povilas Kanapickas (p12) on 2013-11-05
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers