Awn

Can't go to menu when there is a window under the panel

Bug #351623 reported by Julien Lavergne on 2009-03-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn
Low
Unassigned
avant-window-navigator (Debian)
Fix Released
Unknown

Bug Description

From Debian (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=474228) :

When a focus policy of focus follows mouse (xfce) If the pannel apears over a
window then it is impossible to go from the panel to opened menus (such as the
application menu) since they disappear before the mouse reaches them due to the
focus going to the underying window

Related branches

Julien Lavergne (gilir) wrote :

Fixed for 0.4, by pressing Ctrl, the bar disappear.

Changed in awn:
status: New → Fix Committed
Changed in avant-window-navigator:
status: Unknown → New
Julien Lavergne (gilir) on 2009-03-30
Changed in awn:
importance: Undecided → Low
Michal Hruby (mhr3) on 2009-03-30
Changed in awn:
milestone: none → 0.4.0
senten (encheres12) wrote :

I'm not sure I understand the answer.
From what I understand from the reporter, and I have the same problem, the problem is not the bar but the fact that the plugin activated window disappear before you can activate one of its element if you have focus follows mouse AND a window there.

How to reproduce it (tested with gnome and awn 0.3.3 trunk):

activate focus follow mouse (system > preference > select windows when mouse is over).
Install Awn main menu plug in
Click on it in awn
Its windows appears some pixels above the boutons
Clic on the menus in this window, no problem.

Now put a windows, like this browser, under awn so that the gap betwen the awn main menu icon and its windows will be filled filled.
Clic on the awn main menu icon.
The menu window appear above the browser. No problem so far.
But try to reach it, it will disappear as soon as the underlaying windows steal the focus and before you can reach the menus icons.

A longer delay before it disappears when some other windows gets the focus seems the answer?

Changed in avant-window-navigator (Debian):
status: New → Confirmed
moonbeam (rcryderman) on 2010-04-12
Changed in awn:
status: Fix Committed → Fix Released
Changed in avant-window-navigator (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.