Awn

custom icons cannot handle slash in title

Bug #228036 reported by Thinboy00 on 2008-05-08
4
Affects Status Importance Assigned to Milestone
Awn
Medium
haytjes
avant-window-navigator (Ubuntu)
Undecided
Julien Lavergne

Bug Description

To reproduce:
-1. Have awn installed.
0. Have a custom icon set for OpenOffice.org Writer (NOT Writer/Web)
1. Start OpenOffice.org Writer/Web (it has the "/" in the title)
2. Try to set a custom icon -- It won't work, but it's not as if awn can be bothered to tell you via zenity (or something)
3. Close awn and open a terminal
4. type "avant-window-navigator" to start awn. Don't close the terminal (yet)
5. Repeat steps 1 & 2. It will complain

I'm using the bzr version from the Ubuntu repository. This isn't really relevant, but I use compiz-fusion. I am currently using Ubuntu Gusty because an unrelated bug is preventing me from upgrading to Hardy.

Thinboy00 (thinboy00) on 2008-05-08
description: updated
Mark Lee (malept) wrote :

Thanks for the bug report.

Marking as confirmed, as I can definitely imagine forgetting to escape the icon names. h4writer, do you handle this in your rewrite branch?

> It won't work, but it's not as if awn can be bothered to tell you via zenity (or something)

Patches welcome.

> 5. Repeat steps 1 & 2. It will complain

Could you please post the complaining, for completeness's sake?

Changed in awn:
assignee: nobody → h4writer
importance: Undecided → Medium
milestone: none → 0.2.8
status: New → Confirmed
Thinboy00 (thinboy00) wrote :

The complaining:

Failed to open '~/.config/awn/custom-icons/OpenOffice.org-Writer/Web' for writing: Not a directory

Note:home directory replaced with ~ for privacy reasons
I have yet to test whether this is on stdout or stderr. I don't have time to test that right now, but it should be trivial redirection.

The patch:
I am not a proficient enough programmer in any language other than bash to open up another program such as zenity, and I am not very familiar with GUI programming. FYI, I am also not a professional programmer (I am currently a student), so we're lucky I know as much as I do.

Thinboy00 (thinboy00) wrote :

Out of curiosity, how is the milestone 0.2.8? My awn-bzr says it's 0.3.1. Typo?

0.2.8 will be the next stable release of awn-extras. 0.3.1 is the
current development branch of awn itself.

On Thu, May 8, 2008 at 8:25 PM, Thinboy00 <email address hidden> wrote:
> Out of curiosity, how is the milestone 0.2.8? My awn-bzr says it's
> 0.3.1. Typo?
>
> --
> custom icons cannot handle slash in title
> https://bugs.launchpad.net/bugs/228036
> You received this bug notification because you are subscribed to avant-
> window-navigator in ubuntu.
>

black (blackborn) wrote :

fix against r262 of trunk

moonbeam (rcryderman) wrote :

Pushed. Revision 270. Thanks.

Changed in awn:
status: Confirmed → Fix Committed
black (blackborn) on 2008-06-20
Changed in avant-window-navigator:
status: New → In Progress
Julien Lavergne (gilir) on 2008-09-07
Changed in avant-window-navigator:
assignee: nobody → gilir
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.2.6-7ubuntu1

---------------
avant-window-navigator (0.2.6-7ubuntu1) intrepid; urgency=low

  * debian/patches
   - 91-delete-themes.patch : From upstream, allow to delete themes
     other than the current one (LP: #134397).
   - 92-custom-icon-slash-title.patch : From upstream, handle slash in
     custom icons title (LP: #228036).

 -- Julien Lavergne <email address hidden> Sun, 07 Sep 2008 16:33:59 +0200

Changed in avant-window-navigator:
status: In Progress → Fix Released
moonbeam (rcryderman) on 2009-02-09
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers