Awn

Error: Failed to execute child process

Bug #194018 reported by Alvinistic on 2008-02-21
14
Affects Status Importance Assigned to Milestone
Awn
Critical
Mark Lee

Bug Description

I am running awn 0.2.4 using --enable-desktop=xfce4.

When I click on the launcher sometimes the program refused to run. For example, when I tried to run thunar, it gives me this error in terminal:
Error: Failed to execute child process "Thunar" (Bad address)

Several clicks later it launched thunar though. But the error happens very frequently.
FYI, it happens not only to thunar, but also other program's launcher.

moonbeam (rcryderman) on 2008-02-21
Changed in awn:
assignee: nobody → malept
arvind (senorsnor) wrote :

I get the same thing with awn 0.2.6, also using --enable-desktop=xfce4. Usually launchers launch the application without problems, but suddenly, for a while, every time a launcher is clicked nothing happens and "Error: Failed to execute child process "ApplicationName" (Bad address)" is printed to the terminal. After clicking a few times, sometimes once, sometimes several times, but I'd say never more than five times, the applications is launched. After that, all applications launch again without problems, until it happens again. It seems totally random, but happens often enough to become pretty annoying :-)

Mark Lee (malept) on 2008-04-22
Changed in awn:
importance: Undecided → Critical
milestone: none → 0.2.8
status: New → Confirmed
Benoe (benoe77) wrote :

Same here with awn 0.3.1, ubuntu hardy.

The message I got is in hungarian, but it is the same:
"Error: Nem sikerült a gyermekfolyamat („thunderbird”) végrehajtása (Rossz cím)Error: Nem sikerült a gyermekfolyamat („thunderbird”) végrehajtása (Rossz cím)Error: Nem sikerült a gyermekfolyamat („thunderbird”) végrehajtása (Rossz cím)Launched application : 21797"

By the 4th click the application started.

The same occurs with other applications too, like firefox, etc.

nikogawa (nikoraes) wrote :

I also have the same problem in AWN 0.3.1.bzr232.1~hardy (from the PPA) in Ubuntu Hardy

Here it always happens the first few times i try to start something. At this point awn actually isn't usable.
I get this error message (in dutch): Error: Uitvoeren van dochterproces ‘firefox’ is mislukt (Ongeldig adres)
but it happens with every starter.

Benoe (benoe77) wrote :

Today I updated awn with the latest version from Reacocard's PPA, and it seems that the problem is gone.
Thank you.

Götz Christ (g-christ) wrote :

For me this problem is also gone with that update. :)

Thanks!

Mark Lee (malept) on 2008-04-27
Changed in awn:
status: Confirmed → In Progress
black (blackborn) wrote :

Apparently the bug isn't there anymore. So I put the status to 'Fix Released'

Changed in awn:
status: In Progress → Fix Released
moonbeam (rcryderman) wrote :

black,

Are you configuring with --enable-desktop=xfce4? This is the only configuration tht shows the bug.

If you are using this configuration option could you please indicate your system information?

moonbeam (rcryderman) wrote :

Correction to my previous comment. --with-desktop=xfce4 not --enable-desktop=xfce4

moonbeam (rcryderman) wrote :

returning to "In Progress" I have confirmed the issue is still present.

Changed in awn:
status: Fix Released → In Progress
moonbeam (rcryderman) wrote :

I have pushed a possible fix for the issue. Revision 449 of trunk.

Please test.

haytjes (h4writer) wrote :

Can someone plz test the trunk if this bug is still present or is solved, so the bug report can get closed?

Michal Hruby (mhr3) on 2009-01-17
Changed in awn:
milestone: 0.2.8 → 0.3.2
Michal Hruby (mhr3) wrote :

We consider this fixed, please reopen if anyone encounters this problem.

Changed in awn:
status: In Progress → Fix Committed
Mark Lee (malept) on 2009-02-09
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers