Awn

Trash applet appears as a white box when first opened

Bug #161048 reported by noggah on 2007-11-08
4
Affects Status Importance Assigned to Milestone
Awn
Undecided
Unassigned
Awn Extras
Wishlist
Unassigned

Bug Description

When i first open AWN the trash applet appears as a white rectangle for a few seconds

Mark Lee (malept) wrote :

I would consider this a bug for awn-extras, given that the behavior occurs specifically with the trash applet.

Julien Lavergne (gilir) wrote :

Is it appears after some seconds ? I think it only because you have many files in your trash so the applet take some seconds to load.

Changed in awn-extras:
status: New → Incomplete
Changed in awn:
status: New → Invalid
Neil J. Patel (njpatel) wrote :

maybe the applet should show once, and then load the files after a small timeout?

moonbeam (rcryderman) wrote :

At this time it's, of course, seemingly impossible to avoid this happening in all cases... on my older system it happens even with applets specifically written to minimize the chance of this.

Basically the best approach I have found is something like a
1) in the init do the absolute least amount of work needed...
   a) Basically set the icon. If for some reason the icon might involve some overhead work... then set it to a temporary blank icon.
   b) do some variation g_signal_connect_after() on the "realize" or "expose" event for applet. Basically you want to get a signal where you know the white rectangle has been replaced with something

2) Do whatever needs to be done... In some applets I've delayed hooking up most important signals until after this point is reached.

It helps but doesn't completely fix the problem. I think the real fix will be reached when white lines never appear... though I'm not sure what that is, and I have went looking for it a few times.

Neil J. Patel (njpatel) wrote :

White lines are almost definitely due to the gtksocket/gtkplug trying to sort out themselves...I just need to figure out a way to make ti work so it doesn't look horrible!

moonbeam (rcryderman) wrote :

Neil,

As a data point. At one point I went though and gdk_window_set_back_pixmap() to NULL for almost everything I could find. Either I missed the one that mattered for that was a dead end. I'm thinking dead end.

Changed in awn-extras:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Michal Hruby (mhr3) wrote :

Fixed by introducing the Garbage applet.

Changed in awn-extras:
milestone: none → 0.4.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers