Awn

AWN 0.2.1 Doesn't 'Make'

Bug #160845 reported by Corey Farwell on 2007-11-08
4
Affects Status Importance Assigned to Milestone
Awn
Low
Mark Lee

Bug Description

I'm building AWN from the source for version 0.2.1
Here's my paste for if I input 'make:'

corevette@coreycomputer:~/Desktop/avant-window-navigator-0.2.1$ make
make all-recursive
make[1]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1'
Making all in libawn
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/libawn'
make[2]: Circular stamp-awn-enum-types.h <- awn-enum-types.h dependency dropped.make all-am
make[3]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/libawn'
make[3]: Circular stamp-awn-enum-types.h <- awn-enum-types.h dependency dropped.make[3]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/libawn'
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/libawn'
Making all in src
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/src'
make all-am
make[3]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/src'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/src'
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/src'
Making all in awn-applet-activation
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/awn-applet-activation'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/awn-applet-activation'
Making all in data
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/data'
Making all in active
make[3]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/data/active'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/data/active'
make[3]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/data'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/data'
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/data'
Making all in applets
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/applets'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/applets'
Making all in po
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/po'
Making all in pyawn
make[2]: Entering directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/pyawn'
***INFO*** Generating awn.c from awn.defs
Traceback (most recent call last):
  File "/usr/share/pygtk/2.0/codegen/codegen.py", line 1261, in ?
    sys.exit(main(sys.argv))
  File "/usr/share/pygtk/2.0/codegen/codegen.py", line 1213, in main
    ["override=", "prefix=", "register=", "outfilename=",
  File "/usr/lib/python2.4/getopt.py", line 91, in getopt
    opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
  File "/usr/lib/python2.4/getopt.py", line 191, in do_shorts
    if short_has_arg(opt, shortopts):
  File "/usr/lib/python2.4/getopt.py", line 207, in short_has_arg
    raise GetoptError('option -%s not recognized' % opt, opt)
getopt.GetoptError: option -I not recognized
make[2]: *** [awn.c] Error 1
make[2]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1/pyawn'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/corevette/Desktop/avant-window-navigator-0.2.1'
make: *** [all] Error 2
corevette@coreycomputer:~/Desktop/avant-window-navigator-0.2.1$

Some people say if install some other packages, it would work, but the only package that is not in the Debian repositories is: python-gconf

Related branches

Julien Lavergne (gilir) wrote :

You need python-gtk2 with 2.10 version. If you using etch, it's 2.8, so you need to upgrade to newer version.

Changed in awn:
importance: Undecided → Low
status: New → Confirmed
Mark Lee (malept) wrote :

This needs to be addressed in ./configure.in. Attached is a patch (that's also in 0.2-stable-testing) that changes the required version of pygtk from 2.8 to 2.10.

Julien, the patch also has changes for the debian*/control files, so could you review the patch?

Julien Lavergne (gilir) wrote :

To be perfect, we need also libglib2.0-dev (>=2.12) :) But the patch is good, thanks Mark :)

Changed in awn:
status: Confirmed → In Progress
Mark Lee (malept) wrote :

Patch merged in trunk r146.

Changed in awn:
status: In Progress → Fix Committed
Mark Lee (malept) wrote :

Change milestone, assignee.

Changed in awn:
assignee: nobody → malept
milestone: none → 0.2.4
moonbeam (rcryderman) on 2008-02-19
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers