Awn

awn startup behavior

Bug #159217 reported by jdriessen on 2007-11-01
6
Affects Status Importance Assigned to Milestone
Awn
Wishlist
haytjes

Bug Description

this is a request.

when AWN launches at login, it looks bad on my system. The bar appears in the middle, the Icons to the left. and it can take up to ten seconds until the icons have moved from the left side of the screen to the middle (where they're supposed to be)

It may be nicer to have AWN load hidden under the screen, and then appear when ready. (like auto-hide, but in this case "auto-reveal"...?)

my apologies if this is the wrong place to put a feature request. please relocate this ticket to the relevant location if that is the case.

Running Ubuntu 7.10 on Macbook (although this was an issue for me on several other computers and distros)

Julien Lavergne (gilir) wrote :

Thanks for the report. It's the good place for feature request :)

Changed in awn:
importance: Undecided → Wishlist
status: New → Confirmed
mrhat (killamachine) wrote :

Same Problem here. Looks ugly. Ubuntu 7.10 i386 even after clean install. I had the same problem with the 64bit edition.

mrhat (killamachine) wrote :

It's v0.2.1

mrhat (killamachine) wrote :

Obviously the problem is with the autostart order of gnome. When the startup of awn is delayed then the icons are popping up in the middle like they should. Maybe there is some compiz-stuff which needs to be loaded before awn for the visual effects.

Workaround
----------------
Start awn via the following bash:

#!/bin/bash
sleep 3s
avant-window-navigator

Just save it as sh-file somewhere on your hd, and put it in your autostart.

Changed in awn:
status: Confirmed → In Progress
haytjes (h4writer) on 2008-01-08
Changed in awn:
assignee: nobody → h4writer
haytjes (h4writer) wrote :

Made a patch for this one. Patch will be added tomorrow morning by Neil.
(don't have the right equipment --lol-- now to do it)

haytjes (h4writer) on 2008-01-09
Changed in awn:
status: In Progress → Fix Committed
Alpha4 (colligia) wrote :

I'd really appreciate it too.. I have the same problem.
We're all waiting for your patch! :):):)

Thank you very much

haytjes (h4writer) wrote :

Is already added :-D

Mark Lee (malept) on 2008-02-17
Changed in awn:
milestone: none → 0.2.4
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers