Awn

awn-manager doesn't start: Check for null string before setting font button

Bug #144923 reported by GreatSlovakia on 2007-09-25
6
Affects Status Importance Assigned to Milestone
Awn
Undecided
Unassigned

Bug Description

Awn doesn t start with the following error

Traceback (most recent call last):
  File "/usr/local/bin/awn-manager", line 199, in <module>
    awnmanager = AwnManager()
  File "/usr/local/bin/awn-manager", line 100, in __init__
    self.prefManager = awnPreferences(self.wTree)
  File "/usr/local/share/avant-window-navigator/awn-manager/awnPreferences.py", line 152, in __init__
    self.setup_font(TITLE_FONT_FACE, self.wTree.get_widget("selectfontface"))
  File "/usr/local/share/avant-window-navigator/awn-manager/awnPreferences.py", line 279, in setup_font
    font_btn.set_font_name(self.client.get_string(key))
TypeError: GtkFontButton.set_font_name() argument 1 must be string, not None

I know this is like bug #141358, yet the second part of the error is totally different.

Neil J. Patel (njpatel) wrote :

Can you please check latest bzr, it should fix the problem.

Trom (trom303) wrote :

Similar bug here:

$ awn-manager
Traceback (most recent call last):
  File "/usr/bin/awn-manager", line 199, in ?
    awnmanager = AwnManager()
  File "/usr/bin/awn-manager", line 100, in __init__
    self.prefManager = awnPreferences(self.wTree)
  File "/usr/share/avant-window-navigator/awn-manager/awnPreferences.py", line 162, in __init__
    self.setup_color(TITLE_TEXT_COLOR, self.wTree.get_widget("textcolor"))
  File "/usr/share/avant-window-navigator/awn-manager/awnPreferences.py", line 182, in setup_color
    raise "\nKey: "+key+" isn't set.\nRestarting AWN usually solves this issue\n"

Key: /apps/avant-window-navigator/title/text_color isn't set.
Restarting AWN usually solves this issue

Using latest tree:

$ bzr version-info
revision-id: <email address hidden>
date: 2007-10-09 23:29:09 +0200
build-date: 2007-10-12 01:46:05 -0600
revno: 130
branch-nick: avant-window-navigator

Tried this, but didn't fix:

gconftool-2 --recursive-unset /apps/avant-window-navigator

Mark Lee (malept) wrote :

Does this behavior still occur with version 0.2.1?

Changed in awn:
status: New → Confirmed

It has been working since the last time I reinstalled my system... probably even longer, so it was OR a update OR the fact that I din't compiled it myself this time...

Mark Lee (malept) wrote :

Unless you have any objections, I'm marking as fixed in 0.2.1.

Changed in awn:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers