Awn

schema files missing from source

Bug #144310 reported by Neal Gompa on 2007-09-23
6
Affects Status Importance Assigned to Milestone
Awn
Low
Unassigned

Bug Description

I was building a Fedora RPM today using the latest tree as of now from the trunk, and when I built it, the schema files were missing from the package. Though originally there was one schema file, when i started getting it from launchpad, the one schema file disappeared and the two schema files in its place appeared (trash.schemas and switcher.schemas). These files are now gone. I cannot seem to locate any semblance of the schema files anywhere...

Related branches

Julien Lavergne (gilir) wrote :

All applets was moved to awn-extras. So trash, switcher and theirs schemas files are now in awn-extras : https://launchpad.net/awn-extras/

So schemas are not needed for the core of Awn?

On 9/23/07, Julien Lavergne <email address hidden> wrote:
>
> All applets was moved to awn-extras. So trash, switcher and theirs
> schemas files are now in awn-extras : https://launchpad.net/awn-extras/
>
> --
> schema files missing from source
> https://bugs.launchpad.net/bugs/144310
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Neil J. Patel (njpatel) wrote :

They are needed for the core of Awn, but unfortunately, when Awn 0.1 was released, the schema files were not installing properly, and so I made a decision to not use a schema file.

Now, however, I know that Awn should have a proper schema file, but I will add it in the 0.3 release, rather than right now.

Mark Lee (malept) on 2007-11-29
Changed in awn:
status: New → Confirmed
Mateusz Kaduk (mateusz) wrote :

After installing awn on Debian(sid)

~$ awn-manager
Traceback (most recent call last):
  File "/usr/bin/awn-manager", line 200, in ?
    awnmanager = AwnManager()
  File "/usr/bin/awn-manager", line 101, in __init__
    self.prefManager = awnPreferences(self.wTree)
  File "/usr/share/avant-window-navigator/awn-manager/awnPreferences.py", line 150, in __init__
    self.setup_chooser(APP_ACTIVE_PNG, self.wTree.get_widget("activefilechooser"))
  File "/usr/share/avant-window-navigator/awn-manager/awnPreferences.py", line 242, in setup_chooser
    raise "\nKey: "+key+" isn't set.\nRestarting AWN usually solves this issue\n"

Key: /apps/avant-window-navigator/app/active_png isn't set.
Restarting AWN usually solves this issue

Looks like missing schema.

Mark Lee (malept) wrote :

> Looks like missing schema.

Yes, this has been confirmed and will be in version 0.3.

Fix from desktop-agnostic merged into trunk by way of awn-core-testing

Changed in awn:
status: Confirmed → Fix Committed
Mark Lee (malept) on 2008-02-17
Changed in awn:
importance: Undecided → Low
milestone: none → 0.2.4
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers