Awn

Awn-manager doesn't start

Bug #141358 reported by Natan Yellin on 2007-09-20
4
Affects Status Importance Assigned to Milestone
Awn
Undecided
Unassigned

Bug Description

Both Awn-manager and awn-preferences won't start. When I try I get this error:
Traceback (most recent call last):
  File "/usr/local/bin/awn-manager", line 199, in <module>
    awnmanager = AwnManager()
  File "/usr/local/bin/awn-manager", line 94, in __init__
    self.appletManager = awnApplet(self.wTree)
  File "/usr/local/share/avant-window-navigator/awn-manager/awnApplet.py", line 71, in __init__
    self.load_applets()
  File "/usr/local/share/avant-window-navigator/awn-manager/awnApplet.py", line 332, in load_applets
    icon, text = self.make_row (a)
  File "/usr/local/share/avant-window-navigator/awn-manager/awnApplet.py", line 226, in make_row
    return self.make_icon (item.get_string(gnomedesktop.KEY_ICON)), text
  File "/usr/local/share/avant-window-navigator/awn-manager/awnApplet.py", line 246, in make_icon
    icon = gtk.gdk.pixbuf_new_from_file_at_size (name, 32, 32)
gobject.GError: Failed to open file '/usr/share/avant-window-navigator/separator.svg': No such file or directory

I've tried uninstalling and reinstalling from source about 50 times, and it doesn't help. I've tried resetting awn in gconf without success. In the end, I finally just copied another svg file to that directory and renamed it to separator.svg and now it works. Nonetheless, this problem should still be fixed. I've posted more information about this here: http://www.planetblur.org/hosted/awnforum/index.php?shard=forum&action=g_reply&ID=859&page=1&isLive=true

Related branches

Neil J. Patel (njpatel) on 2007-09-28
Changed in awn:
status: New → Confirmed
Mark Lee (malept) wrote :

Does this behavior still occur with trunk?

Natan Yellin (aantny) wrote :

I don't know.

I'm using a fresh install of Gutsy now (before I was on Feisty) and it works fine.

I think that its probably fixed.

Julien Lavergne (gilir) wrote :

I close this, seems to be resolve.
Feel free to reopen it.

Changed in awn:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers