Awn

gdk_screen_is_composited needs gtk2.10

Bug #138341 reported by haytjes on 2007-09-08
4
Affects Status Importance Assigned to Milestone
Awn
High
haytjes

Bug Description

In the new code there is a function that needs Gtk2.10: gdk_screen_is_composited. Now it isn't a big deal if GTK 2.08 is installed. Then we just do no checking for compositing manager and that is solved to. I have already a patch, but I can't test this one. So please could someone test this patch with GTK2.08 and someone commit this one, because I'm gone till Wednesday.

haytjes (h4writer) wrote :
Changed in awn:
assignee: nobody → h4writer
importance: Undecided → High
status: New → Confirmed
Michal Hruby (mhr3) wrote :

I think this will not work, the function is still there and linker will not be able to link it. You have to use preprocessor to make it work.
Anyway I didn't test it as I do not have GTK 2.08 so there's a slight chance I'm wrong.

haytjes (h4writer) wrote :

@ Michal, you're right.

Now can someone test this one. This one works with preprocessing and should normally work.

haytjes (h4writer) on 2007-09-12
Changed in awn:
status: Confirmed → Fix Committed
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments