Awn

Cannot remove any theme in awn-manager except the currently enabled one

Bug #134397 reported by Emiliano on 2007-08-24
26
Affects Status Importance Assigned to Milestone
Awn
Undecided
Mark Lee
avant-window-navigator (Ubuntu)
Low
Julien Lavergne

Bug Description

When trying to remove an installed theme, awn-manager doesn't remove it, unless it is the currently selected radio box entry. In other words, it only removes it if the highlighted and "selected" entries are the same.

This is the terminal output when attempting to remove a highlighted but not selected theme:

Traceback (most recent call last):
  File "/usr/share/avant-window-navigator/awn-manager/awnTheme.py", line 311, in delete
    index = self.model.get_path(self.currItr)[0]
TypeError: iter should be a GtkTreeIter

Ryan Rushton (ryancr) wrote :

I see whats happening, if you only highlight the row and try to delete you get that error message, but if you select the radio button then click delete it will work.

I can confirm what Ryan is saying above. While you can delete themes if the radial button is clicked you can't if the theme is only highlighted.

It seems to me that the most intuitive and user friendly way for this to function is for the radial button to indicate the active theme at the moment while the highlighted theme is what actions will be applied to. Right now the highlight doesn't seem to do any thing. This is confusing for the end user as the highlight stands out much more than the radial button.

Changed in awn:
status: New → Confirmed
Julien Lavergne (gilir) wrote :

Also reported on Ubuntu Hardy (version 0.2.1)

Changed in avant-window-navigator:
status: New → Confirmed
Changed in avant-window-navigator:
importance: Undecided → Low
Götz Christ (g-christ) wrote :

I have the same behavior. The radio button should be delete, and it should be possible to only have to select the theme to "really" select it.

Michael Rooney (mrooney) on 2008-06-06
description: updated
Michael Rooney (mrooney) on 2008-06-06
description: updated
black (blackborn) wrote :

I've made a patch.

Now it does every action on the selected theme. The radio button only shows the current theme and will change to the selected theme if you hit the 'Apply' button

black (blackborn) on 2008-06-20
Changed in awn:
status: Confirmed → In Progress
Changed in avant-window-navigator:
status: Confirmed → In Progress
Michael Rooney (mrooney) wrote :

Thanks black. I am reviewing this patch and it works much better than before. One comment and one issue, however.

1) The section "@@ -346,7 +349,7 @@" can be removed since that was already fixed as a separate patch, which you did (thanks!).

2) There is a bug when removing a theme in the same place that a theme was already removed from. For example, have >2 themes installed. Remove the first one, no problem. Try removing the new first one, which used to be the second:

  File "/usr/share/avant-window-navigator/awn-manager/awnTheme.py", line 315, in delete

    name = self.theme_list[index]['name']

  KeyError: 0

  The same thing happens if you remove say the second theme if you had three, and now try to remove the "second" theme again which used to be the third.

  Deceptively, theme_list is actually a dictionary, so that is probably the issue.

Other than that I can remove multiple themes, including selected and unselected ones, change applied themes and remove more, et cetera. It seems quite robust except for that aforementioned bug. Do you think it is something you can fix? Thanks!

black (blackborn) wrote :

New patch with solution for above problem.

Michael Rooney (mrooney) wrote :

Great work black, I reviewed the patch and it looks good. I tested it and it works very well, I can't seem to break it in any way! This patch has my go-ahead for 0.2.7/trunk.

Mark Lee (malept) on 2008-08-24
Changed in awn:
assignee: nobody → malept
milestone: none → 0.2.8
Mark Lee (malept) wrote :

Fixed in trunk in revision 474. It will be in the 0.2.7 branch shortly.

Changed in awn:
status: In Progress → Fix Committed
Julien Lavergne (gilir) on 2008-09-07
Changed in avant-window-navigator:
assignee: nobody → gilir
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.2.6-7ubuntu1

---------------
avant-window-navigator (0.2.6-7ubuntu1) intrepid; urgency=low

  * debian/patches
   - 91-delete-themes.patch : From upstream, allow to delete themes
     other than the current one (LP: #134397).
   - 92-custom-icon-slash-title.patch : From upstream, handle slash in
     custom icons title (LP: #228036).

 -- Julien Lavergne <email address hidden> Sun, 07 Sep 2008 16:33:59 +0200

Changed in avant-window-navigator:
status: In Progress → Fix Released
moonbeam (rcryderman) on 2009-02-09
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions