Awn

simple mouse wheel implementation

Bug #134377 reported by Ceceppa on 2007-08-23
2
Affects Status Importance Assigned to Milestone
Awn
Wishlist
Awn Testing Team

Bug Description

I've add a simple routine for mouse wheel implementation that allow to switch fastly to / from other window.
when SCROLL_UP window will put on current viewport, while SCROLL_DOWN, restore it on original position and restore focus on last window.

patch: http://files-upload.com/files/454583/awn.patch
i hope that it is useful

Isaac Joseph (isaacj87) wrote :

So, you're saying that if I go down to my Firefox icon and scroll either up or down it will switch to different windows?

Il giorno ven, 24/08/2007 alle 17.06 +0000, isaacj87 ha scritto:
> So, you're saying that if I go down to my Firefox icon and scroll either
> up or down it will switch to different windows?
>

if you scroll up on the icon of the non-active window it will be
activated
and shown in the current viewport
then scroll down to put the window in background and select the last
window
active.

example:
I have two windows open : firefox (active) and pidgin
if i want to reply on chat i can
salect pidgin
look and relpy
go back to firefox

with the patch:
i can scrool up and scrool down on the icons to switch to firefox or
pidgin

 I think it's a good idea in case you have much window open, because it
allows you too see the state of another window and then go back to your
"work"
or it allows you to bring the window in the active viewport, with a
simple
scrool on one icon!

In attachment you can find correct patch.

Ceceppa (senesealessandro) wrote :
Neil J. Patel (njpatel) wrote :

This is cool, but I'll probably way to commit until after the 0.2 release.

Changed in awn:
status: New → Confirmed
Julien Lavergne (gilir) on 2008-01-05
Changed in awn:
importance: Undecided → Wishlist
Julien Lavergne (gilir) wrote :

Thanks for the patch.
I added it to the awn-testing branch to test it before include it in trunk.

Changed in awn:
assignee: nobody → awn-testing
status: Confirmed → In Progress

I've tried this w/ awn-testing and it seems to work as described fine. Very neat... One suggestion though, I don't find this very useful unless it also works with active launchers as well. Scrolling with the mouse wheel currently has no effect on the first window opened by a program which has a launcher on the dock since its icon doesn't need to appear in the task-manager.

revno: 161
committer: Julien Lavergne <seagle@justice>
branch nick: awn-core-trunk
timestamp: Sat 2008-01-12 23:53:39 +0100
message:
 2008-01-12 Julien Lavergne <email address hidden>

       * awn-manager/awnApplet.py:
       * src/awn-task.c:
       Merge revision 158 and 159 of awn-core-testing branch
       - Close #158182 : Sort applets alphabetically in awn-manager (Patch from Timon_and_Pumba)
       - Close #134377 : Mouse wheel implementation (Patch from Ceceppa)
modified:
 ChangeLog
 awn-manager/awnApplet.py
 src/awn-task.c

Changed in awn:
status: In Progress → Fix Committed
Changed in awn:
status: Fix Committed → Fix Released
Mark Lee (malept) on 2009-08-31
Changed in awn:
milestone: 1.0.0 → 0.2.4-milestone
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers