Awn

Window list and launcher should be separate applets

Bug #134096 reported by Rodney on 2007-08-22
36
Affects Status Importance Assigned to Milestone
Awn
Wishlist
Neil J. Patel

Bug Description

This isn't really a bug, more of a feature request. I would like to have the option of not having the window list in AWM, but I want launchers. I think the two should be separate applets.

Timon_and_Pumba (timonterbraak) wrote :

When applet support arrived for Awn, the task/launch feature was converted to internal applets. Now its time to convert them to "real" applets.

Changed in awn:
importance: Undecided → Wishlist
Michal Hruby (mhr3) wrote :

I totally agree with Timon...
Launchers and Tasks should be separate "real" applets. Only then will get the applets framework powerful enough to do anything. ;)

spanella (spanella) wrote :

Definitely interested in this feature
should also be a separate applet to define the area to minimize open windows (seperate from the task list of course)
a nice smooth animation into thumbnails on the bar would be a plus ;) (would require compiz integration i suppose)

Neil J. Patel (njpatel) on 2007-09-28
Changed in awn:
assignee: nobody → njpatel
status: New → Confirmed
Pismenny Andrey (apismenny) wrote :

In other words many users (including me) want to have Mac OS-like dock with an integrated launcher/task switcher and an area for minimized windows. I hope AWN will be able to work like this some happy day.

jdriessen (j-driessen) wrote :

I would definately like to see this become a reality, it is one of the few things that stop me from using AWN.

slonkak (kevinslonka) wrote :

Agreed. I'm pretty disappointed that if I want to open more than 1 xterm from my launcher, I can't because 1 is already open. This should behave like the OSX bar, where the launcher and open app are 2 separate icons, launchers on the left, open apps on the right. So if you have an xterm open you'd have one icon for the launcher, then another for the open app.

Mark Lee (malept) wrote :

I believe Neil is working on this for the 0.3 release. However, it should be noted that there is no timeline for 0.3 right now, for various reasons.

TWO (two) wrote :

When can we expect to see this feature implemented?

Mark Lee (malept) wrote :

Whenever it is Neil finishes his rewrite. See also my previous answer.

moonbeam (rcryderman) on 2010-11-28
Changed in awn:
status: Confirmed → Fix Committed
Jano (janoxakespam) on 2011-04-11
Changed in awn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers