Awn

Wrong awn location when using xrandr 1.2

Bug #133702 reported by Javier Cabezas on 2007-08-20
2
Affects Status Importance Assigned to Milestone
Awn
Medium
haytjes

Bug Description

I'm using xrandr 1.2 in order to easily manage external monitors with my laptop. When I plug it I get a bigger desktop, where the external monitor shows the top of the desktop and the laptop's screen the bottom. When I start awn, it appears in the middle of the external screen while it should appear at the bottom of the laptop's screen. An screenshot is attached.

I am using Ubuntu Gutsy, compiz fusion, xrandr 1.2, xorg 7.2, and awn HEAD (bzr revision 53). The laptop is an Intel Core Macbook with an integrated Intel 945GM graphics chipset. The resolution of the external monitor is 1280x1024, while the laptop's screen resolution is 1280x800.

Javier Cabezas (javier-cabezas) wrote :
Isaac Joseph (isaacj87) wrote :

Open up Gconf...
Go to apps->avant-window-navigator

Adjust the "monitor_height" to 1024 and and check "Force Monitor"

See if that works for you.

Javier Cabezas (javier-cabezas) wrote :

Yes, it works now. But I think it's only valid as a temporal workaround since I must change the gconf values if the resolutions of the monitor/s change. I would keep the bug open.

Neil J. Patel (njpatel) wrote :

This something I wish to work on in the next release (in which I plan to internally support xrandr). Hence I am setting the milestone to 0.3.

Changed in awn:
importance: Undecided → Medium
status: New → Confirmed
haytjes (h4writer) wrote :

Busy fixing this issue. Only need to test it myself, but I don't have gutsy (my brother has), therefor you will have to wait till I get him to test it.
(But there will still a problem if twinview is chosen without xrandr 1.2, because than you only can get the big screen and there are no hints how big the screens are.)

Changed in awn:
assignee: nobody → h4writer
status: Confirmed → In Progress
haytjes (h4writer) wrote :

Here is the patch. Can some guys confirm it works under different configurations, before I commit it?

haytjes (h4writer) on 2007-09-05
Changed in awn:
status: In Progress → Fix Released
haytjes (h4writer) on 2007-09-05
Changed in awn:
status: Fix Released → Fix Committed
Javier Cabezas (javier-cabezas) wrote :

It works better now. However, it is still placed in the upper monitor (the external one) of my vertical virtual desktop (I execute "xrandr --output LVDS --mode 1280x800 --output VGA --mode 1280x1024 --above LVDS"). Furthermore, as I use the "automatically hide" option of awn, it hiddes from the upper monittor but appears on the top of my laptop's screen.

0.2.1 released

Changed in awn:
status: Fix Committed → Fix Released
Mark Lee (malept) on 2009-08-31
Changed in awn:
milestone: 1.0.0 → 0.2.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Bug attachments