Awn

Unmet dependencies on debian jessie

Bug #1328994 reported by Nathan Schramm on 2014-06-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn
Undecided
Unassigned

Bug Description

I tried to install AWN on debian testing using your latest saucy repositories and ran into dependency errors. An update for AWN would be greatly appreciated.

avant-window-navigator:
 Depends: libawn1 but it is not going to be installed
 Depends: libdesktop-agnostic0 but it is not going to be installed
  Depends: libwnck22 (>=1:2.22) but 2.30.7-1 is to be installed
 Depends: avant-window-navigator-data but it is not going to be installed
 Depends: libdesktop-agnostic-bin but it is not going to be installed
 Depends: libdesktop-agnostic-vfs
 Depends: libdesktop-agnostic-fdo
 Depends: libdesktop-agnostic-cfg-gconf but it is not going to be installed
 Recommends: awn-applets-python-core but it is not installable
 Recommends: awn-applets-c-core but it is not installable
 Recommends: awn-settings but it is not going to be installed
 Recommends: dockmanager but it is not installable

Povilas Kanapickas (p12) wrote :

Hi,

The issue with Debian is that AWN depends on packages removed form debian altogether. IIRC the most problematic one is libgladeui or something like that. This wouldn't be solved without significant work on the AWN side. I'm currently doing a large rewrite of AWN which will, among other things, solve this issue. The rewrite is being done privately at the moment -- completely broken builds do not benefit anyone.

cb474 (cb474) wrote :

Did this rewrite every happen? Is there a way to install AWN in Debian (Jessie)? Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers