Awn

"Emptying the Trash" dialog problem

Bug #129787 reported by Andrew Starr-Bochicchio on 2007-08-01
2
Affects Status Importance Assigned to Milestone
Awn
Medium
haytjes

Bug Description

Right clicking on the trash applet gives the option to empty the trash. Selecting that brings up a "Emptying the Trash" dialog which appears to hang after deleting files and you must select cancel to clsoe the dialog. In reality the trash is empty, but for the user this can be very confusing. The dialog should either close when finished or the button should be relabeled "done" or "complete."

This is most definitely a bug with the applet, but this applet has been committed to AWN's source.

Bryan Haskins (bryan-h) wrote :

Confirmed, assuming this is easily replicated for any hackers on that plugin as well.

searayman (mikejones3) on 2007-08-02
Changed in awn:
importance: Undecided → Medium
status: New → Confirmed
haytjes (h4writer) wrote :

Here is a patch that lets the dialog go away. But I think it would be better if the dialog stays a second or something, because now you can't see that the dialog hits 100% ...

Changed in awn:
assignee: nobody → h4writer
haytjes (h4writer) on 2007-08-03
Changed in awn:
status: Confirmed → In Progress
haytjes (h4writer) on 2007-08-03
Changed in awn:
status: In Progress → Fix Released
searayman (mikejones3) wrote :

i have latest bzr and this is not fixed for me... when i empty the trash it still stays up.....

haytjes (h4writer) wrote :

Strange, is the dialog saying that 100% is removed?

Isaac Joseph (isaacj87) wrote :

Works for me, but only with one condition:

That I don't have any locked files in my trash

I guess you could consider it a bug, but if you have locked files in your trash and you try to empty the trash, the dialog box will stay up. It doesn't give you the typical "can't delete you don't have permission" type dialog box.

searayman (mikejones3) wrote :

here is a screenshot of what happens:

http://farm2.static.flickr.com/1042/1032552710_5a149f923e.jpg?v=0

the trash says 1 of 2....hmmm and I only have one item in the trash i thought....maybe what isaacj87 is right.

But i do not see any other files in the trash folder....

Isaac Joseph (isaacj87) wrote :

Yeah...I'm pretty sure that's it...

Go into your trash...do ctrl+h and you'll see the hidden file causing you trouble.

haytjes (h4writer) wrote :

This has nothing to do with this bug (reported here). The dialog only go away when everything is removed. Now not everything is removed, so it's acting like it should and the dialog stays open.

So I made a new bug report here:
https://bugs.launchpad.net/awn/+bug/130841

searayman (mikejones3) wrote :

i already have done a crt+H to see hidden files but I see nothing.....

what is the path to the trash? I want to do an ls command in there and see if it sees anything...

haytjes (h4writer) wrote :

the path to your trash is: ~/.Trash

searayman (mikejones3) wrote :

I don't see anything in my trash with an ls:

mike@mike-desktop:~$ cd .Trash/
mike@mike-desktop:~/.Trash$ ls
mike@mike-desktop:~/.Trash$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches