Awn

Switching viewports via AWN does not update tasks

Bug #129703 reported by Michael Rooney on 2007-08-01
4
Affects Status Importance Assigned to Milestone
Awn
Undecided
Unassigned

Bug Description

This bug applies to having AWN configured to only show windows from the current viewport (I hope I am using the correct word here). If you open an application you have added as a launcher, it becomes a task (loses the arrow), but is always visible no matter what viewport you are in. This makes sense, however, if you click it from a different viewport, you will be switched the viewport it is in, but the task icons next to the launchers will not be updated. You have to click on another window or the desktop, and then the icons from the old viewport will be removed and the appropriate ones added.

If this is not clear let me use an example. Windows A and B are open in Viewport 1. Windows C and D are open in Viewport 2. You are in Viewport 1. AWN contains one launcher application, and Windows A and B. Click launcher application. Switch to Viewport 2. AWN now contains the launcher application and Windows C and D. All good so far! NOW click the launcher again, which should switch you to Viewport 1. AWN does not update though. It still shows Windows C and D. Clicking the desktop or another window will remove C and D and show A and B.

This is on Ubuntu 7.04 with Compiz Fusion, if that has any effect.

kevinbeard (kevinbeard) wrote :

I just recreated this with the latest version.

One thing to note is that it only occurs when you are using the desktop cube. If you use the expo plugin instead and manually switch back, everything is fine.

kevinbeard (kevinbeard) wrote :

Here's a patch that seams to fix the problem

Michael Rooney (mrooney) wrote :

Wow, thanks for such a quick patch! I can confirm that this has solved the problem for me.

And you were correct, it is using the desktop cube. If you change it manually, it always worked, but perhaps because the focus changed.

Thanks again. Hopefully this makes it into the SVN soon so the next update doesn't cause a regression for me.

Thanks for the patch. Merged and fixed.

Changed in awn:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers