Awn

Beryl/Compiz window previews don't work

Bug #129678 reported by Miika-Petteri Matikainen on 2007-08-01
6
Affects Status Importance Assigned to Milestone
Awn
Medium
Miika-Petteri Matikainen
Changed in awn:
status: New → Confirmed
Rafał Próchniak (burlap) wrote :

Just for the record, so it doesn't get lost (it's been mentioned in the original bug report/forums): the previews work with auto-hide on. After switching auto-hide off, they don't.

haytjes (h4writer) wrote :

Ok, after further studding:

1) active auto_hide
( window preview aren't working )
2) go off the bar (the bar auto_hides)
3) let the bar come up
( window preview are working: place = on the bottom )
4) the bar is up
( window preview are working: place = on the bottom with bar_height between the bottom and the window preview = right place)
5) go to the bottom of the bar and to the left/right until your not longer on the and go up (the bar doesn't hide)
6) go back on the bar
(window preview is again not working)

aquahawk (shane71717) wrote :

Just to add they work tested on the lastest compiz fusion from git with 214 of awn so this is a regression caused by one of the patches its not a compiz/beryl bug..

Fixed in the latest revision.

Changed in awn:
assignee: nobody → mpmatikainen
importance: Undecided → Medium
status: Confirmed → Fix Released
haytjes (h4writer) wrote :

can you tell what was wrong? Just curious :-)

nice it is fixed

It seems that your reflection patch changed the size of the icon geometry incorrectly in awn_task_refresh_icon_geometry (awn-task.c).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers