Awn

Cannot launch avant-preferences

Bug #129639 reported by Szilveszter Farkas on 2007-08-01
22
Affects Status Importance Assigned to Milestone
Awn
Undecided
haytjes

Bug Description

When running 'avant-preferences' from a terminal, I get the following traceback:

/usr/local/share/avant-window-navigator/window.glade
Traceback (most recent call last):
  File "/usr/local/bin/avant-preferences", line 273, in <module>
    app = main()
  File "/usr/local/bin/avant-preferences", line 158, in __init__
    self.setup_chooser(APP_ACTIVE_PNG, self.wTree.get_widget("activefilechooser"))
  File "/usr/local/bin/avant-preferences", line 240, in setup_chooser
    chooser.set_filename(self.client.get_string(key))
TypeError: GtkFileChooser.set_filename() argument 1 must be string, not None

Using trunk (revno 10).

haytjes (h4writer) wrote :

I can only reproduce this bug/error when I manual unset the key '/apps/avant-window-navigator/app/active_png' in gconf-editor.

To get it working again, just restart avant-window-navigator. AWN sets the default value for this key on startup. After startup you must be able to run avant-preferences again.

greetz

haytjes (h4writer) wrote :

Now busy to let avant-preferences trigger an error when this happens that says you need to restart AWN.

Changed in awn:
status: New → In Progress
assignee: nobody → h4writer
Szilveszter Farkas (phanatic) wrote :

Running avant-window-navigator solved the problem. Thanks!

Although it should really produce a user-friendly error message, or just continue...

haytjes (h4writer) wrote :

done

Changed in awn:
status: In Progress → Fix Released
Kyubutsu (jf) wrote :

confirmed again on 8.04 hardy x86_64 - gateway mt-3422

   terminal output:
Screen is composited.
APPLET : /usr/lib/awn/applets/taskman.desktop
Failed to execute child process "awn-manager" (No such file or directory)

Mark Lee (malept) wrote :

Did you install the awn-manager package?

thanks Mark, i had the same problem with Szilveszter. This problem solved after I install the awn-manager.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers