Awn

Xfce4 support

Bug #129606 reported by Mark Lee on 2007-08-01
10
Affects Status Importance Assigned to Milestone
Awn
Medium
Mark Lee

Bug Description

(from <http://code.google.com/p/avant-window-navigator/issues/detail?id=169>)

I'm working on a branch that tries to be desktop-agnostic. It allows AWN to be optionally compiled and run with libxfce4util and thunar-vfs instead of gnome-desktop, libgnome, and gnome-vfs. Additionally, it tries to use an ini-style format for configuration instead of gconf.

Instead of uploading patches (as I did on Google Code), a branch will be registered, labeled "desktop-agnostic".

Great! What is the status of this branch?

Changed in awn:
importance: Undecided → Medium
status: New → Confirmed
Mark Lee (malept) wrote :

I just published the branch. Xfce4 support seems to be complete, but I'd recommend testing it before merging. You never know what I missed. It works for me(tm), at least, both activating launchers and switching apps. The rest of the status of the branch is documented on the branch's whiteboard.

Neil J. Patel (njpatel) wrote :

I really like this idea, but this is the way that I'd like it implemented:

All desktop file related functions moved to libawn in awn-desktop-file.[h|c], and the rest of the code updated to use this code.

awn_desktop_file_* can handle how to access desktop files depending on how it was compiled, gnome/xfce/something else. This also means that I can tell all applet developers to use libawn to access desktop files, in addition to keeping the code really clean.

Mark Lee (malept) wrote :

I've (finally) committed support for the API Neil described, and I've changed all of the code in awn to take advantage of it. If someone could review it, that would be great. FYI, my hosted branch is probably more recent than the Launchpad mirrored one - I just committed a couple of post-merge fixes.

Mark Lee (malept) wrote :

FYI, the branch is still active - I've added a libegg implementation for desktop entries to be used in both xfce and desktop-agnostic mode. (There are still a few bugs with that, but they will be dealt with soon.) Also, I'm working on a better config API that takes a backend of either GConf or GKeyFile (glib's interface to .ini-style files). There's a blueprint on Launchpad for that.

Changed in awn:
assignee: nobody → malept
Changed in awn:
status: Confirmed → In Progress
Mark Lee (malept) wrote :

I'm proud to say that desktop-agnostic has been merged into trunk (by way of awn-core-testing). I'm not marking it as "fix committed" just yet, because I still want to make sure that the non-Gnome version of AwnDesktopItem works well. I haven't had any problems with the non-Gnome versions of AwnConfigClient or AwnVfsMonitor.

Mark Lee (malept) on 2008-02-14
Changed in awn:
milestone: none → 0.2.4
Michal Hruby (mhr3) wrote :

Mark isn't this already released in 0.2.6? Can you mark as fix released, or move the milestone please?

Changed in awn:
milestone: 0.2.4 → 0.3.2
Michal Hruby (mhr3) on 2009-01-19
Changed in awn:
milestone: 0.3.2 → 0.4.0
Mark Lee (malept) on 2010-04-12
Changed in awn:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers