Awn

awn-settings crashes on launch

Bug #1195161 reported by Steven Miller on 2013-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn
High
Unassigned

Bug Description

Running on NetBSD 6.1 i386 compiled from pkgsrc-current.

Version: 0.4.0

Window manager: xfce4 4.6.1

Video card: ATI Rage 128 Pro Ultra TR (AGP) 16MB

Xserver: X.Org X Server 1.10.3

-------------------------------------------------------------------------------
When attempting to launch 'awn-settings', I get this error,

** (process:393): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:393): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:393): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
  File "/usr/pkg/bin/awn-settings", line 53, in <module>
    from awnClass import awnPreferences, awnManager, awnLauncher, awnApplet, awnThemeCustomize, awnTaskManager
  File "/usr/pkg/share/avant-window-navigator/awn-settings/awnClass.py", line 45, in <module>
    from awnSettingsHelper import bind_to_gtk_component
  File "/usr/pkg/share/avant-window-navigator/awn-settings/awnSettingsHelper.py", line 20, in <module>
    from desktopagnostic import config
  File "/usr/pkg/lib/python2.7/site-packages/desktopagnostic/__init__.py", line 20, in <module>
    from desktopagnostic.desktopagnostic import *
ImportError: /usr/pkg/lib/python2.7/site-packages/desktopagnostic/desktopagnostic.so: Undefined PLT symbol "pydesktopagnostic_register_classes" (symnum = 4)

I'm not certain how to proceed. There is no core file being generated.

Thanks in advance,
Steven

Steven Miller (srmj71) wrote :

Is this a dead project? I've been hoping to get some assistance with this issue.

Marc MAURICE (dooblem) wrote :

Hi Steven,

Yes, the project is almost dead at the moment.
Fact is that we have to make awn compatible with the last vala version.
Some of us started working on it but apparently time is hard to find.

Marc

Povilas Kanapickas (p12) on 2013-11-02
Changed in awn:
status: New → Confirmed
importance: Undecided → High
Povilas Kanapickas (p12) wrote :

As far as I remember this was caused by an obsolete python and libdesktop-agnostic -related package. I think it is fixed in recent testing PPA packages. Thus closing as fixed. Feel free to reopen if this is not the case.

Thanks!

Changed in awn:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers