Common Folder Launcher shows 3 icons for my home folder.

Bug #793257 reported by Derek White on 2011-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Low
onox

Bug Description

Exact order of icons, with the "duplicate" folders numbered.

1) "Home Folder" followed by Desktop and Documents.
2) "<username/home folder name>" followed by Pictures and Videos.
3) "<username/home folder name>" followed by Public and Templates.
The 3 remaining icons are filled out with other home directory folders.

I expected each folder to only be listed once. What I got instead was my home folder being listed 3 times.

Using: 0.4.1-rewrite-bzr830+201104200103 from http://ppa.launchpad.net/awn-testing/ppa/ubuntu maverick main

Related branches

Derek White (d-man97) on 2011-06-05
description: updated
description: updated
onox (onox) wrote :

Do you find any duplicates in .gtk-bookmarks in your home folder? (It's a hidden file, so you probably need to do Ctrl+H in Nautilus or do cat ~/.gtk-bookmarks in a terminal)

Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → Low
status: New → Incomplete
tags: added: common-folder-launcher
Derek White (d-man97) wrote :

No duplicates, but I did see an entry for a ~/Downloads folder that is non-existent. Removed that entry and put applet back on AWN.

In nautilus, I removed all the default bookmarks, I only have 2 entries (after removing ~/Downloads) in my .gtk-bookmarks.

Applet now puts "Home Folder" and "<username" folder - only 2 now! I guess that's an improvement!

Then, I noticed something (maybe the applet?) re-created previously deleted folders: Music and Documents. Deleted them from my home folder, removed applet, re-added applet.

Now:
Home Folder > Desktop > Pictures > Videos > <username> > Public > Templates > the all my custom bookmarks (all 2 of them!)

onox (onox) wrote :

The applet doesn't create or delete folders. It only monitors whether the special XDG folders (in the following order: Documents, Music, Pictures, Videos, Downloads, Public, Templates) and your local (non-remote) bookmarks exist. If they exist, then it shows an icon for them. If the applet detects you or another application removed a special XDG folder or bookmarked local folder, then it hides the corresponding icon.

So it displays an icon for your home folder, your desktop, the special XDG folders (only those that exist in your home folder) and then your bookmarks (for local bookmarks only those that exist -- remote ones are always displayed) If one of your bookmarks is in fact a special XDG folder, then it ignores it (to avoid duplicates)

----------------------------------------------------------------------

If I look at the position of the unwanted user/home icons, then they seem to correspond with: Documents, Music, and Downloads. You removed Documents, and Music. And then those icons disappeared in the applet if I understand you correctly, leaving only Downloads to remain.

That makes me think that something created Downloads because the applet shouldn't show an icon for it if the folder doesn't exist.

Can you open a terminal and then start "python". Then type:

import glib
print glib.get_user_special_dir(glib.USER_DIRECTORY_DOWNLOAD)
print glib.get_user_special_dir(glib.USER_DIRECTORY_MUSIC)
print glib.get_user_special_dir(glib.USER_DIRECTORY_DOCUMENTS)
print glib.get_user_special_dir(glib.USER_DIRECTORY_PICTURES)

Just type each line and then press enter, the prints should print the path to the directory.

Derek White (d-man97) wrote :

>>> import glib
>>> print glib.get_user_special_dir(glib.USER_DIRECTORY_DOWNLOAD)
/home/derek
>>> print glib.get_user_special_dir(glib.USER_DIRECTORY_MUSIC)
/home/derek
>>> print glib.get_user_special_dir(glib.USER_DIRECTORY_DOCUMENTS)
/home/derek
>>> print glib.get_user_special_dir(glib.USER_DIRECTORY_PICTURES)
/home/derek/Pictures
>>>

After now restarting since last comment:
Home > Desktop > derek > derek > Pictures > Videos > derek > Public > Templates > custom bookmarks

~$ \ls
Desktop edghog netbeans-7.0 Pictures Public Templates Ubuntu One Videos
~$

I would have to assume that it is displaying them all, even though they "match" my home folder.

onox (onox) wrote :

Thanks for the reply. I'll fix the applet to ignore a special XDG folder if it points to your home folder.

Changed in awn-extras:
milestone: none → 0.4.2
status: Incomplete → Confirmed
Derek White (d-man97) wrote :

No problem. Glad I could help!

I'll await the fix and let you know how it works out for me.

onox (onox) wrote :

Fixed in revision 1536.

Changed in awn-extras:
status: Confirmed → Fix Committed
Povilas Kanapickas (p12) on 2013-11-17
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers