TypeError in Battery Status: super() argument 1 must be type, not classobj

Reported by Phillip Mabry on 2010-09-22
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox

Bug Description

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1540, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/battery/battery.py", line 86, in __init__
    self.check_status_cb()
  File "/usr/share/avant-window-navigator/applets/battery/battery.py", line 218, in check_status_cb
    time = self.backend.get_charge_time()
  File "/usr/share/avant-window-navigator/applets/battery/battery.py", line 433, in get_charge_time
    return super(UPowerBackend, self).get_charge_time()
TypeError: super() argument 1 must be type, not classobj

applet version: 0.4.1

AWN was installed and operating, this error popped up after I updated as suggested by Ubuntu update manager. I orignially installed AWN from the Ubuntu Software Center and have been using it as my primary window manager, with no bugs, for about 1 month.

AWN appears to work fine when I close out the error, but no battery update. I am not sure of my video card, I am using a Toshiba Sattelite P205-S7806 with no hardware upgrades.

Related branches

onox (onox) wrote :

Which version of ubuntu _and_ which version of python do you have?

Changed in awn-extras:
assignee: nobody → onox (onox)
status: New → Incomplete
tags: added: battery traceback

Ubuntu: 10.04
python: 2.6.5

On Wed, Sep 22, 2010 at 2:56 PM, onox <email address hidden> wrote:

> Which version of ubuntu _and_ which version of python do you have?
>
> ** Changed in: awn-extras
> Status: New => Incomplete
>
> ** Changed in: awn-extras
> Assignee: (unassigned) => onox (onox)
>
> ** Tags added: battery traceback
>
> --
> TypeError in Battery Status: super() argument 1 must be type, not classobj
> https://bugs.launchpad.net/bugs/645440
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Awn Extras: Incomplete
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1540, in
> init_start
> applet_class(applet)
> File "/usr/share/avant-window-navigator/applets/battery/battery.py", line
> 86, in __init__
> self.check_status_cb()
> File "/usr/share/avant-window-navigator/applets/battery/battery.py", line
> 218, in check_status_cb
> time = self.backend.get_charge_time()
> File "/usr/share/avant-window-navigator/applets/battery/battery.py", line
> 433, in get_charge_time
> return super(UPowerBackend, self).get_charge_time()
> TypeError: super() argument 1 must be type, not classobj
>
> applet version: 0.4.1
>
> AWN was installed and operating, this error popped up after I updated as
> suggested by Ubuntu update manager. I orignially installed AWN from the
> Ubuntu Software Center and have been using it as my primary window manager,
> with no bugs, for about 1 month.
>
> AWN appears to work fine when I close out the error, but no battery update.
> I am not sure of my video card, I am using a Toshiba Sattelite P205-S7806
> with no hardware upgrades.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/awn-extras/+bug/645440/+subscribe
>

onox (onox) wrote :

Thanks for providing the information.

Changed in awn-extras:
importance: Undecided → Medium
milestone: none → 0.4.2
status: Incomplete → Confirmed
onox (onox) wrote :

Fixed in revision 1413. Please wait for a new PPA to appear.

Changed in awn-extras:
status: Confirmed → Fix Committed
Povilas Kanapickas (p12) on 2013-11-17
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers