Scaling unavailable in CPU Frequency Monitor

Bug #554586 reported by Patrick Lindsey on 2010-04-03
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox

Bug Description

Scaling unavailable. Frequency scaling is not available for the selected CPU. When the I add a similar applet to the top panel scaling works fine.

Installed on the 10.04 beta 1
Installed using Synaptics Package Manager
0.4.0~rc1-0ubuntu1
Gnome 2.30.0
Graphics chip: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
Driver in use: radeon
Rendering method: AIGLX

CPU info while running @ 800MHz

processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) Neo X2 Dual Core Processor L335
stepping : 2
cpu MHz : 800.000
cache size : 256 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips : 1595.92
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) Neo X2 Dual Core Processor L335
stepping : 2
cpu MHz : 800.000
cache size : 256 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips : 1595.92
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

Related branches

onox (onox) on 2010-04-04
summary: - CPU Frequency Monitor
+ Scaling unavailable in CPU Frequency Monitor
onox (onox) wrote :

Do you have the cpufreq-selector binary on your system?

Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → Medium
status: New → Incomplete
tags: added: applet cpufreq

On 4/4/10, onox <email address hidden> wrote:
> Do you have the cpufreq-selector binary on your system?

I am not sure how to tell actually. I went to the synaptics package
manager and typed cpufreq-selector and there were no packages to
select from. Also, I just noticed that the bar does not change colors
when the CPU changes frequencies. Should it and do I need to submit
another bug?

Patrick

Kyle L. Huff (kylehuff) wrote :

Onox, I thought I would add that I also cannot use the Scaling applet; I do however have gnome-cpufreq applet - I use it daily.

The Scaling applet (AWN) says that scaling is not available for the selected CPU, regardless of which CPU I select (0 or 1). It detects both CPU's and when I have CPU 0 selected the hover tool-tip shows the correct current frequency, but when I have CPU 1 selected it always shows the lowest available frequency.

Output of `lscpu`:
Architecture: i686
CPU(s): 2
Thread(s) per core: 1
Core(s) per socket: 2
CPU socket(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 14
Stepping: 8
CPU MHz: 800.000
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 2048K

Not sure if this is the same issue as the OP, but if you believe it is, I can be found as usual in #awn and can do some testing/debugging if you like.

Kyle

onox (onox) wrote :

You need to have a directory like /sys/devices/system/cpu/cpu0/cpufreq/ and the cpufreq-selector binary in your path (type "which cpufreq-selector" in a terminal).

I currently use a very small python script, but it has been chmodded SUID, which means it will run as root. According to the Awn core devs this will trigger some chain reaction of neurons in the brains of Linux distribution devs (read: core devs think that distribution devs don't want to install that script if I would distribute it along with Awn Extras), so instead I need to write some code that starts a DBus service object (to be automatically started by DBus) (I still think as root if you want to be able to change the values in /sys) + PolicyKit. Since PolicyKit only has API reference manual for the C language and there is no proper manual with examples, it's gonna take some time to find out how this stuff works. I need to read and try to understand gnome's cpufreq-selector code (which is written in a certain old unreadable deprecated language from the early 70's (read: C)).

@kylehuff: I don't idle in #awn anymore, so I'll contact you in a private message if necessary

Changed in awn-extras:
status: Incomplete → Confirmed
Michal Hruby (mhr3) wrote :

@onox: Please take a look at this patch, it should fix the scaling support (tested on Karmic). Now it asks for password when changing the freq/governor (though that's same as the gnome-panel applet).

onox (onox) wrote :

Should be fixed in revision 1280. Fix based on patch by mhr3.

Changed in awn-extras:
status: Confirmed → Fix Committed
milestone: none → 0.4.0
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Patrick Lindsey

Patrick Lindsey
Student at University of South Florida
Tampa/St. Petersburg, Florida Area

Confirm that you know Patrick Lindsey
https://www.linkedin.com/e/fmid8h-gfed3ene-21/isd/1790169578/VATT4opO/

--
(c) 2010, LinkedIn Corporation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers