Weather: [Errno 104] Connection reset by peer

Bug #510840 reported by Dilomo on 2010-01-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox

Bug Description

error in Weather: [Errno 104] Connection reset by peer

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/threadqueue.py", line 64, in run
    r = func(*args, **kwargs)
  File "/usr/share/avant-window-navigator/applets/weather/weather.py", line 186, in bound_func
    return func(obj, *args, **kwargs)
  File "/usr/share/avant-window-navigator/applets/weather/weather.py", line 623, in get_weather_map
    result = re.findall(mapExp, usock.read())
  File "/usr/lib/python2.6/socket.py", line 329, in read
    data = self._sock.recv(rbufsize)
  File "/usr/lib/python2.6/httplib.py", line 518, in read
    return self._read_chunked(amt)
  File "/usr/lib/python2.6/httplib.py", line 567, in _read_chunked
    value.append(self._safe_read(amt))
  File "/usr/lib/python2.6/httplib.py", line 615, in _safe_read
    chunk = self.fp.read(min(amt, MAXAMOUNT))
  File "/usr/lib/python2.6/socket.py", line 353, in read
    data = self._sock.recv(left)
error: [Errno 104] Connection reset by peer

applet version: '0.3.9'
Ubuntu 9.10
I installed via repository
I used Emerald
Nvidia GeForce 7600GS with driver v 185

Mark Lee (malept) on 2010-01-21
summary: - [Errno 104] Connection reset by peer
+ Weather: [Errno 104] Connection reset by peer
tags: added: applet network traceback weather
Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → Medium
Michal Hruby (mhr3) on 2010-03-27
Changed in awn-extras:
milestone: none → 0.4.0
onox (onox) wrote :

Can you still reproduce this? It may be the case that the error will be catched and handled since a revision somewhere in Februari.

Changed in awn-extras:
status: New → Incomplete
Michal Hruby (mhr3) on 2010-04-15
Changed in awn-extras:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers