AttributeError in YAMA: 'NoneType' object has no attribute 'contents'

Bug #506847 reported by Karim Rekik on 2010-01-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox
awn-extras-applets (Ubuntu)
Medium
Julien Lavergne

Bug Description

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 97, in __init__
    self.build_menu()
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 120, in build_menu
    self.append_directory(tree.root, self.menu, item_list=self.applications_items)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 510, in append_directory
    for node in tree.contents:
AttributeError: 'NoneType' object has no attribute 'contents'
    - applet version: '0.3.9'

Error when I tried to add "yet another menu" applet

Mint 6 XFCE CE (built on Ubuntu Intrepid)
XFCE 4.6 with XFCE compositor
Awn 3.9.1
bzr1934 and 1942
i396
NVIDIA GeForce4 MX 4000.
NVIDIA Driver version : 96.43.09

onox (onox) on 2010-01-13
Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → High
milestone: none → 0.4.0
status: New → Confirmed
tags: added: applet traceback yama
Michal Hruby (mhr3) on 2010-04-15
Changed in awn-extras:
milestone: 0.4.0 → 0.4.2
onox (onox) wrote :

Can you show me which .menu files you have in /etc/xdg/menus/ ? If you cannot find the directory in your file browser (thunar??) then open a console and do ls -alhF $XDG_CONFIG_DIRS/menus/

Changed in awn-extras:
status: Confirmed → Incomplete
Julien Lavergne (gilir) on 2010-08-26
Changed in awn-extras-applets (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
onox (onox) wrote :

@Goran Zdjelar: do you use Gnome or xfce or something else? Please also look at my previous comment.

onox (onox) on 2010-09-11
Changed in awn-extras:
importance: High → Medium
onox (onox) wrote :

Hopefully (because no one provided the information I requested) fixed in revision 1411.

Changed in awn-extras:
status: Incomplete → Fix Committed
Julien Lavergne (gilir) on 2010-09-23
Changed in awn-extras-applets (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awn-extras-applets - 0.4.0+bzr1372-0ubuntu3

---------------
awn-extras-applets (0.4.0+bzr1372-0ubuntu3) maverick; urgency=low

  * debian/control:
   - Build-depends on libindicator-dev (>= 0.3.14) to rebuild on lastest
     libindicator. (LP: #637692).
  * debian/patches/901-cairo-menu-fix-d-and-d.patch:
   - From upstream, fix drag and drop in cairo-menu. (LP: #568700)
  * debian/patches/902-mail-fix-pop-backend.patch:
   - From upstream, fix POP3 backend in mail applet (LP: #561919)
  * debian/patches/903-mail-fix-io-error.patch:
   - From upstream, unlock keyring on startup in mail applet (LP: #581075)
  * debian/patches/904-mail-fix-crash-on-toggle.patch
   - From upstream, Fix crash on_toggle() in mail applet (LP: #557410)
  * debian/patches/905-yama-fix-crash-nonetype.patch
   - From upstream, fix NoneType crash in YAMA applet (LP: #506847)
  * debian/patches/906-mail-desktop-icon.patch
   - From upstream, fix icon in desktop file of mail applet.
 -- Julien Lavergne <email address hidden> Fri, 24 Sep 2010 16:04:00 +0200

Changed in awn-extras-applets (Ubuntu):
status: In Progress → Fix Released
Coman Mihai (z0id) wrote :

I still get this error on Archlinux, awn 0.4.0, gnome 3, pythnon 2.7.2

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 98, in __init__
    self.build_menu()
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 131, in build_menu
    self.append_directory(tree.root, self.menu, item_list=self.settings_items)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 511, in append_directory
    for node in tree.contents:
AttributeError: 'NoneType' object has no attribute 'contents'

Coman Mihai (z0id) wrote :

$ ls -alhF $XDG_CONFIG_DIRS/menus/
total 24K
drwxr-xr-x 3 root root 4,0K mai 27 11:19 ./
drwxr-xr-x 7 root root 4,0K aug 5 01:41 ../
-rw-r--r-- 1 root root 4,0K apr 27 00:46 applications.menu
drwxr-xr-x 2 root root 4,0K mai 14 03:18 applications-merged/
-rw-r--r-- 1 root root 407 mai 14 03:18 ggz.menu
-rw-r--r-- 1 root root 2,8K mai 24 12:12 gnomecc.menu

Povilas Kanapickas (p12) on 2013-11-17
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers