AttributeError in Mail applet: Settings instance has no attribute 'load_preferences' after each logon or applet restart

Bug #503828 reported by juky on 2010-01-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Awn Extras
High
onox

Bug Description

Ubuntu 9.10 Karmic
- applet version: '0.3.9'

AWN installed via repository - http://ppa.launchpad.net/awn-testing/ppa/ubuntu

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 67, in __init__
    self.setup_context_menu()
  File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 220, in setup_context_menu
    self.setup_preferences(prefs)
  File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 238, in setup_preferences
    self.settings = self.awn.settings.load_preferences(default_values)
AttributeError: Settings instance has no attribute 'load_preferences'

Gnome window manager used.

Video card: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
Video driver: X.Org X server -- Intel i8xx, i9xx display driver 2:2.9.0-1ubuntu2

Mark Lee (malept) on 2010-01-06
tags: added: applet mail traceback
Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → High
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers