Settings instance has no attribute 'load_preferences'

Bug #502639 reported by qwertz1287 on 2010-01-03
282
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Awn Extras
High
Julien Lavergne

Bug Description

Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/awn/extras/awnlib.py", line 1438, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 106, in __init__
    self.setup_preferences()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 272, in setup_preferences
    self.settings = self.applet.settings.load_preferences(default_settings)
AttributeError: Settings instance has no attribute 'load_preferences'

applet version: '0.3.9'

Changed in awn-extras:
assignee: nobody → Grega Podlesek (muscardinus)
Grega Podlesek (muscardinus) wrote :

Please explain how to reproduce this bug.

Changed in awn-extras:
status: New → Incomplete
moonbeam (rcryderman) wrote :

It's related to some recent changes made to awnlib. I'd suggest asking onox.

Sebastian Rau (sebastian.rau) wrote :

Had this bug too, my traceback:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1438, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/battery/battery.py", line 80, in __init__
    self.setup_context_menu()
  File "/usr/share/avant-window-navigator/applets/battery/battery.py", line 124, in setup_context_menu
    self.settings = self.applet.settings.load_preferences(default_values)
AttributeError: Settings instance has no attribute 'load_preferences'

It is reproducable when I try to add the "Battery State" Applet to the dock.

Systeminformation:
applet version 0.3.9
Ubuntu 9.10
Kernel 2.6.31-16-generic
Gnome 2.28.1

Mark Lee (malept) on 2010-01-03
tags: added: applet awnlib battery hardware-sensors
Changed in awn-extras:
assignee: Grega Podlesek (muscardinus) → onox (onox)
importance: Undecided → High
status: Incomplete → Confirmed
Casey J Peter (caseyjp1) wrote :

Traceback from my system:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1438, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/quit/quit.py", line 100, in __init__
    self.load_settings()
  File "/usr/share/avant-window-navigator/applets/quit/quit.py", line 235, in load_settings
    self.settings = self.applet.settings.load_preferences(defaults)
AttributeError: Settings instance has no attribute 'load_preferences'

Casey J Peter (caseyjp1) wrote :

To reproduce, just start Avant Window Navigator 0.3.9-rewrite-bzr1861-karmic1-1 with the hardware sensors applet or the 'quit-logout' applet on the panel.

Traceback from the hardware sensors crash:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1438, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 106, in __init__
    self.setup_preferences()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 272, in setup_preferences
    self.settings = self.applet.settings.load_preferences(default_settings)
AttributeError: Settings instance has no attribute 'load_preferences'

tags: added: quit-logout
onox (onox) wrote :

quit applet is fixed in revision 1914.

Casey J Peter (caseyjp1) wrote :

I confirm that as as of 1916 the quit applet is functioning again normally.

The hardware sensors is, however, still crashing. Traceback:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 106, in __init__
    self.setup_preferences()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 272, in setup_preferences
    self.settings = self.applet.settings.load_preferences(default_settings)
AttributeError: Settings instance has no attribute 'load_preferences'

There's also the same problem while loading the Cairo Clock applet into the
panel.

Version: Avant Window Navigator 0.3.9-rewrite-bzr1860-jaunty1-1

2010/1/4 Casey J Peter <email address hidden>

> I confirm that as as of 1916 the quit applet is functioning again
> normally.
>
> The hardware sensors is, however, still crashing. Traceback:
>
> Traceback (most recent call last):
> File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1462, in
> init_start
> applet_class(applet)
> File
> "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py",
> line 106, in __init__
> self.setup_preferences()
> File
> "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py",
> line 272, in setup_preferences
> self.settings = self.applet.settings.load_preferences(default_settings)
> AttributeError: Settings instance has no attribute 'load_preferences'
>
> --
> Settings instance has no attribute 'load_preferences'
> https://bugs.launchpad.net/bugs/502639
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Awn Extras: Confirmed
>
> Bug description:
> Traceback (most recent call last):
> File "/var/lib/python-support/python2.6/awn/extras/awnlib.py", line 1438,
> in init_start
> applet_class(applet)
> File
> "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py",
> line 106, in __init__
> self.setup_preferences()
> File
> "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py",
> line 272, in setup_preferences
> self.settings = self.applet.settings.load_preferences(default_settings)
> AttributeError: Settings instance has no attribute 'load_preferences'
>
> applet version: '0.3.9'
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/awn-extras/+bug/502639/+subscribe
>

onox (onox) wrote :

cairo-clock should be in revision 1924.

onox (onox) wrote :

+fixed

onox (onox) on 2010-01-04
tags: added: mail traceback
Jlew (jlew-blackout) wrote :

I got the same error with the mail applet. It looks like you said it was fixed, but here is the extra information in case anyone searches/goes to report it for the mail applet.

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 67, in __init__
    self.setup_context_menu()
  File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 220, in setup_context_menu
    self.setup_preferences(prefs)
  File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 238, in setup_preferences
    self.settings = self.awn.settings.load_preferences(default_values)
AttributeError: Settings instance has no attribute 'load_preferences'

Simon (simon-chatain) wrote :

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 106, in __init__
    self.setup_preferences()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 272, in setup_preferences
    self.settings = self.applet.settings.load_preferences(default_settings)
AttributeError: Settings instance has no attribute 'load_preferences'

- applet version: '0.3.9'

Mark Lee (malept) wrote :

To be clear, the following applets still need to be fixed:

 * battery
 * hardware-sensors
 * mail

Hi Mark,

I wasn't sure if it is duplicate, you confirmed it.

Thanks,
Juraj

-----Original Message-----
From: Mark Lee <email address hidden>
Reply-to: Bug 502639 <email address hidden>
To: <email address hidden>
Subject: [Bug 502639] Re: Settings instance has no attribute
'load_preferences'
Date: Wed, 06 Jan 2010 16:04:02 -0000

To be clear, the following applets still need to be fixed:

 * battery
 * hardware-sensors
 * mail

Doug Morgan (doug-morgan) wrote :

Got it on my system:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1462, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 106, in __init__
    self.setup_preferences()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 272, in setup_preferences
    self.settings = self.applet.settings.load_preferences(default_settings)
AttributeError: Settings instance has no attribute 'load_preferences'

ChrisPoole (chrispoole) wrote :

My system updated to 0.3.9.1~bzr1942-1.9.10 (karmic) which has fixed the remaining applets for me, specifically battery, hardware-sensors and mail.

Thanks!

hi,

I just update the system today, and Awn rollback to :

Avant Window Navigator 0.3.9-rewrite-bzr1891-karmic1-1

and yes, every thing goes right,,,,,

Br,

Raul

2010/1/12 ChrisPoole <email address hidden>

> My system updated to 0.3.9.1~bzr1942-1.9.10 (karmic) which has fixed the
> remaining applets for me, specifically battery, hardware-sensors and
> mail.
>
> Thanks!
>
> --
> Settings instance has no attribute 'load_preferences'
> https://bugs.launchpad.net/bugs/502639
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Awn Extras: Confirmed
>
> Bug description:
> Traceback (most recent call last):
> File "/var/lib/python-support/python2.6/awn/extras/awnlib.py", line 1438,
> in init_start
> applet_class(applet)
> File
> "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py",
> line 106, in __init__
> self.setup_preferences()
> File
> "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py",
> line 272, in setup_preferences
> self.settings = self.applet.settings.load_preferences(default_settings)
> AttributeError: Settings instance has no attribute 'load_preferences'
>
> applet version: '0.3.9'
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/awn-extras/+bug/502639/+subscribe
>

--
Brs

Raul

Changed in awn-extras:
status: Confirmed → Fix Released
Casey J Peter (caseyjp1) wrote :

with 1891, I can confirm that the hardware sensors issue is fixed. Good stuff folks!

onox (onox) on 2010-01-12
Changed in awn-extras:
status: Fix Released → Fix Committed
Julien Lavergne (gilir) wrote :

Just set it to fix committed, fix released will be when a new version will be released.

Changed in awn-extras:
assignee: onox (onox) → Julien Lavergne (gilir)
juky (juraj-belina) wrote :

Confirmed to be working in mail applet with 1891! Congratulations!

onox (onox) on 2010-04-12
Changed in awn-extras:
milestone: none → 0.4.0
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers