cairo-clock crashes by GThread-ERROR

Bug #497865 reported by aealsaady on 2009-12-17
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox

Bug Description

the cairo clock applet crashes after a week of installation and it's giving me this error
GThread-ERROR **: GThread system may only be initialized once.
aborting...
Im using Avant Window Navigator 0.3.9-rewrite-bzr1801-karmic1-1
and my video card is Nvidia 8600GT

Sorry for my bad english......

Mark Lee (malept) wrote :

For future reference, bugs specific to cairo-clock need to go into the Awn Extras bug tracker, as that is where cairo-clock is distributed.

affects: awn → awn-extras
Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → Medium
tags: added: applet cairo-clock
onox (onox) wrote :

When you activate a new instance of cairo-clock in awn-settings, does it crash immediately?

Changed in awn-extras:
status: New → Incomplete
aealsaady (ahmadalsaady) wrote :

It crashes immediately showing me the sad face

onox (onox) wrote :

Are there other applets which crash with the same error? Check weather, volume-control, thinkhdaps, yama, quit.

aealsaady (ahmadalsaady) wrote :

Everything is working good except the Cairo-clock applet

onox (onox) wrote :

If other applets except cairo-clock are working then I'm kinda at a loss. Did you update any software when it started happening?

One thing you could try (but if it works, the applets I mentioned should have crashed) is this;

1) open /usr/[local/]lib/python2.6/site-packages/awn/extras/awnlib.py

site-packages may be dist-packages or something on your ubuntu. Use your imagination to find the file.

2) go to line 1579 (near the end of the file) and prepend gobject.threads_init with a #

3) add a new cairo-clock instance via awn-settings

Tell me if cairo-clock keeps crashing.

aealsaady (ahmadalsaady) wrote :

It worked but only on guest session

onox (onox) wrote :

Marking as "won't fix" since I cannot reproduce it here and there have been no other reports on this issue.

Changed in awn-extras:
status: Incomplete → Won't Fix
summary: - cairo clock is not working
+ cairo-clock crashes by GThread-ERROR
Changed in awn-extras:
milestone: none → 0.4.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers