Error in Hardware Sensors: invalid matrix (not invertible)

Bug #481857 reported by mutty on 2009-11-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Low
Grega Podlesek

Bug Description

applet version: '0.3.9'

Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/awn/extras/awnlib.py", line 1575, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 109, in __init__
    self.setup_icon()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/hardware-sensors.py", line 173, in setup_icon
    self.settings["hand_color"])
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/sensoricon.py", line 51, in __init__
    self.create_background()
  File "/usr/share/avant-window-navigator/applets/hardware-sensors/sensoricon.py", line 84, in create_background
    self.__height / svg_width, self.__height / svg_height)
Error: invalid matrix (not invertible)

onox (onox) on 2009-11-13
Changed in awn-extras:
assignee: nobody → Grega Podlesek (muscardinus)
onox (onox) wrote :

Scaling parameters are used in a matrix that needs to be invertible. This matrix will only be invertible when both parameters are not zero. I had had this problem too a time ago in cairo-clock and I fixed it (iirc) by making svg_width and svg_height floats via float().

Changed in awn-extras:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.4.0
onox (onox) on 2009-12-07
tags: added: applet hardware-sensors traceback
onox (onox) wrote :

Please tell how to reproduce this error.

Changed in awn-extras:
status: Confirmed → Incomplete
Grega Podlesek (muscardinus) wrote :

This bug has been open a long time without anyone replicating it, so I'm closing it.

Changed in awn-extras:
status: Incomplete → Invalid
VasiaUVI (vasiauvi) wrote :

"Error in Hardware Sensors: invalid matrix (not invertible)"
Visit Launchpad and report the bug by following these steps:

1) Paste the error summary text in the 'summary' field
2) Press Continue and then check whether the bug has already been reported or not
3) If you continue and report the bug, paste the following in the big textarea:
    - the traceback
    - applet version: '0.4.1'
    - other info requested by the guidelines found below the big textarea

This is what I got when I've started my PC and awn. I will see if after the second restart the same error appear...

onox (onox) wrote :

@VasiaUVI: this bug certainly isn't going to get fixed by pasting the error dialog (which explains how to file a bug). It sounds like you can understand some bit of English because you found this bug, but you didn't provide the info the help message told you to do, which is:
- the traceback
- other info requested by the guidelines found below the big textarea

You told us it happens everytime you restart the applet. So my question is: does it happen immediately for new applets of hardware-sensors or only after you make changes to the preferences? (maybe after a reboot / restart of Awn)

Changed in awn-extras:
status: Invalid → Incomplete
onox (onox) on 2011-01-16
Changed in awn-extras:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers