Weather applet does not automatically refresh

Bug #468717 reported by Marcos Jr on 2009-11-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox

Bug Description

The weather applet gets stuck on refreshing (with a strange black square icon) when my system starts. I guess that this is happening because awn starts before my wifi connection and so, does not refresh the wheather applet. I have to manually make it refresh after the internet connection starts.

---
* Distribution: Ubuntu 9.10 (Karmic)
* Method of installing Awn: From ppa repo: http://ppa.launchpad.net/awn-testing/ppa/ubuntu
* Awn version: 0.3.9-rewrite-bzr1631-karmic1-1
* Window manager: Default of karmic with compiz
* Video card and driver name/version: nVidia GeForce Go 6150 - Driver version 185

Related branches

Marcos Jr (junalmeida) wrote :
Mark Lee (malept) wrote :

Moving the bug to awn-extras.

Per the bug reporting guidelines on the "Report a bug about Avant Window Navigator" page:

> PLEASE NOTE: If your bug is specific to one applet (as opposed
> to *all* applets, or the entire dock), please file your bug at the
> awn-extras bugtracker: https://bugs.launchpad.net/awn-extras/

affects: awn → awn-extras
Changed in awn-extras:
importance: Undecided → Medium
tags: added: applet weather
onox (onox) on 2009-11-02
Changed in awn-extras:
assignee: nobody → onox (onox)
status: New → Confirmed
deadalnix (deadalnix) wrote :

I got A patch :

In weather.py file, find
     def activate_refresh_cb(self, widget=None, map=True):

(line 275 but I have modified the file so I'm not sure).

Remplace the line :

self.refresh_conditions()

by this code :

        if self.refresh_conditions() == None:
            print "Weather Applet : Failed to retrieve data, refresh in 10s . . ."
            self.applet.timing.delay(self.activate_refresh_cb, 10.0)
            return False

So, if the applet cannot retrieve data, it try again in 10s .

onox (onox) wrote :

Thanks for the patch. I'm going to review and refactor some of the network code of weather to make it more robust and I will hopefully also fix the missing-icon icon (black square) (it should show the logo of The Weather Channel).

Changed in awn-extras:
status: Confirmed → Triaged
deadalnix (deadalnix) wrote :

Sorry to not have done a more complete patch, but I don't know python so I have made a quick fix.

onox (onox) on 2009-12-21
Changed in awn-extras:
status: Triaged → In Progress
milestone: none → 0.4.0
onox (onox) on 2009-12-21
summary: - weather applet does not automatically refreshs
+ Weather applet does not automatically refresh
onox (onox) wrote :

Fixed in revision 1873. If the applet fails to retrieve conditions, forecast, or map, it will retry up to 3 times (10 seconds currently between each attempt). If it still fails after 3 times, it shows a notification.

Changed in awn-extras:
status: In Progress → Fix Committed
Casey J Peter (caseyjp1) wrote :

seems to be working on my system fine as of 1873.

Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments