"open desktop client" on mail applet does nothing

Bug #462540 reported by edonia on 2009-10-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
Grega Podlesek

Bug Description

I can fill in any program to the "Mail Applet Preferences" page. If I hit the "open desktop client" button, just nothing happens.

Avant Window Navigator 0.3.9-rewrite-bzr1615-jaunty1-1

Related branches

Mark Lee (malept) on 2009-10-28
tags: added: applet mail
Changed in awn-extras:
assignee: nobody → Grega Podlesek (muscardinus)
importance: Undecided → Medium
milestone: none → 0.4.0
edonia (uwe-ufritz) wrote :

The issue is, that there ist a private function, which is not working.
When i cahnge the following:

line 194 from:
    def __showDesk(self):
to:
    def showDesk(self):

line 326 from:
        b.connect("clicked", lambda x: self.__parent.__showDesk())
to:
        b.connect("clicked", lambda x: self.__parent.showDesk())

Then it is working!

Grega Podlesek (muscardinus) wrote :
Changed in awn-extras:
status: New → Fix Committed
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers