YAMA (places): IndexError: list index out of range

Bug #461624 reported by mattman on 2009-10-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox

Bug Description

Installed on Ubuntu Jaunty 9.04 from the AWN testing PPA. AWN version bzr-1603 AWN Extras version bzr-1755. Applet version 0.3.9. Running compiz ATi 9200 video card with open source ati driver. The applet worked fine after first installing AWN 0.3.9 but quit working after a reboot.

Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/awn/extras/awnlib.py", line 1582, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 84, in __init__
    self.create_places_submenu(self.menu)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 252, in create_places_submenu
    self.append_volumes()
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 363, in append_volumes
    item = self.create_menu_item(name, icons[1], tooltip)
IndexError: list index out of range

Mark Lee (malept) on 2009-10-27
summary: - 'IndexError in YAMA: list index out of range'
+ YAMA (places): IndexError: list index out of range
tags: added: applet traceback yama
Changed in awn-extras:
assignee: nobody → onox (onox)
importance: Undecided → Medium
SteveLong (steveandbrit) wrote :

confirmed on Karmic as well:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1582, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 84, in __init__
    self.create_places_submenu(self.menu)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 252, in create_places_submenu
    self.append_volumes()
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 363, in append_volumes
    item = self.create_menu_item(name, icons[1], tooltip)
IndexError: list index out of range

*******************************************************

applet version: '0.3.9'

*******************************************************

Ubuntu 9.10 RC Karmic
Installed AWN bzr .3.9.1~bzr1603-1.9.10 through repos
Window manager: GTK
Video Card: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Laptop, Lenovo x61 Tablet
need anything else, just message me!

Changed in awn-extras:
status: New → Incomplete
status: Incomplete → New
Mark Lee (malept) on 2009-10-27
Changed in awn-extras:
status: New → Confirmed
onox (onox) wrote :

Can you go to line 363 in yama.py, and insert the following text on the line above it:

print icons

Please then run avant-window-navigator in console and try to reproduce the IndexError again, you should then see some output in the console. Please paste the output.

Changed in awn-extras:
milestone: none → 0.4.0

Have been unable to reproduce the error other than the first time.

Sent from my iPod

On Oct 28, 2009, at 12:20 PM, onox <email address hidden> wrote:

> Can you go to line 363 in yama.py, and insert the following text on
> the
> line above it:
>
> print icons
>
> Please then run avant-window-navigator in console and try to reproduce
> the IndexError again, you should then see some output in the console.
> Please paste the output.
>
> ** Changed in: awn-extras
> Milestone: None => 0.4.0
>
> --
> YAMA (places): IndexError: list index out of range
> https://bugs.launchpad.net/bugs/461624
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Awn Extras: Confirmed
>
> Bug description:
> Installed on Ubuntu Jaunty 9.04 from the AWN testing PPA. AWN
> version bzr-1603 AWN Extras version bzr-1755. Applet version 0.3.9.
> Running compiz ATi 9200 video card with open source ati driver. The
> applet worked fine after first installing AWN 0.3.9 but quit working
> after a reboot.
>
>
> Traceback (most recent call last):
> File "/var/lib/python-support/python2.6/awn/extras/awnlib.py", line
> 1582, in init_start
> applet_class(applet)
> File "/usr/share/avant-window-navigator/applets/yama/yama.py", line
> 84, in __init__
> self.create_places_submenu(self.menu)
> File "/usr/share/avant-window-navigator/applets/yama/yama.py", line
> 252, in create_places_submenu
> self.append_volumes()
> File "/usr/share/avant-window-navigator/applets/yama/yama.py", line
> 363, in append_volumes
> item = self.create_menu_item(name, icons[1], tooltip)
> IndexError: list index out of range

onox (onox) wrote :

Previously the code assumed the list in "icons" always had at least 2 elements. New code reduces this list to only those icons that are exist. The assumption is made that there's always at least 1 element. The list contains fallback icon names though, so I don't expect the list to be empty.

Changed in awn-extras:
status: Confirmed → Won't Fix
onox (onox) on 2009-12-23
Changed in awn-extras:
status: Won't Fix → Fix Committed
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
Snooze (a6547233) wrote :

I think I'm getting this one on 0.4.1 from the testing repo.

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/awn/extras/awnlib.py", line 1540, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 95, in __init__
    self.build_menu()
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 125, in build_menu
    self.create_places_submenu(self.menu)
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 261, in create_places_submenu
    self.append_bookmarks()
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 368, in append_bookmarks
    icon = self.get_icon_name(info.get_attribute_object(gio.FILE_ATTRIBUTE_STANDARD_ICON))
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 394, in get_icon_name
    return self.get_first_existing_icon(icon.get_names())
  File "/usr/share/avant-window-navigator/applets/yama/yama.py", line 399, in get_first_existing_icon
    return filter(self.icon_theme.has_icon, icons)[0]
IndexError: list index out of range

onox (onox) wrote :

@Snooze: your bug has a different traceback, so please file a new bug report. Make sure you have fully updated all packages related to Awn and its extras/applets. Please also provide information requested in the bug report guide lines (below the bug report form) See http://wiki.awn-project.org/OmnibusBugReportPolicy for more information.

onox (onox) wrote :

@Snooze; see bug #651689

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers