White square appears when no connection to check mail

Bug #407598 reported by Nickzeff on 2009-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
Grega Podlesek

Bug Description

On Ubuntu 9.04, AWN 0.3.2

I have the mail applet running and connecting to my gmail account.

If I start a session and wireless has not connected before AWN has loaded the applets, then there is a connection error. The problem is that the notification comes in the form of a white square in the middle of the screen.

This can be closed by clicking into the white area and pressing the space bar (thereby activating the invisible "OK" button).

I know it is a connection notification, because if I move around the white area, the pointer becomes a caret. If I then try to select whatever is there (difficult since I can't see the text) and paste it into a text editor, the following text can be seen:

There seem to be problems with our connection to your account. Your best bet is probably to log out and try again.

Related branches

Nickzeff (nick) wrote :
Nickzeff (nick) wrote :

Please note that the connection error notification DOES appear correctly if I click the "retry" (blue circular arrow) button on the applet menu while there is no network connection.

So it something to do with the dialog window not being drawn correctly when the session is just starting up?!

Mark Lee (malept) on 2009-10-16
tags: added: applet
Changed in awn-extras:
assignee: nobody → Grega Podlesek (muscardinus)
importance: Undecided → Medium
Grega Podlesek (muscardinus) wrote :

Fixed in rev. 1251
Network errors now shown through libnotify, instead of a dialog window. So this is no longer a problem

Changed in awn-extras:
status: New → Fix Committed
Matt (mjz) on 2010-03-29
Changed in awn-extras:
milestone: none → 0.4.0
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments