cairo menu submenus disconnect

Bug #371094 reported by Dirk on 2009-05-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Awn Extras
Undecided
moonbeam

Bug Description

Recently it's happening quite often that a sub menu is popping up inches above where it should be, i.e. with no connection to the point where the mouse is (see attachment). This is a bit similar to the overlapping problem (bug 202167) in that it appears to occur randomly.

 Currently I am using 0.3.3~bzr564-1.9.04 on Jaunty with Gnome/Metacity/Compiz.

Dirk (rptq) wrote :
Mark Lee (malept) on 2009-05-03
Changed in awn-extras:
assignee: nobody → moonbeam (rcryderman)
status: New → Confirmed
tags: added: applet cairo-menu
Dirk (rptq) wrote :

Here is another screenshot, looks kinda funny. While I am writing this, the Office menu is ok again, but now the Graphics menu and a few others are not. If a submenu goes into that mode then it will pop up disconnected every time I select it. This takes a while, then it behaves normally again.

The version is now bzr565. The AWN dock is not visible in the screenshot because I have "auto hide" switched on. In Compiz I have "click to focus" off, "raise on click" on and "auto-raise" off. Don't know whether that's relevant or not. When I enable "click to focus", it doesn't make a difference except that now a different menu is misbehaving.

Dirk (rptq) wrote :

I may have a workaround: If the a submenu pops up disconnected, I move the mouse pointer from the menu entry that I am on to screen background. At this point, the selection of the menu entry is removed, but cairo menu does not loose the focus. Then I move the mouse back to the same menu entry. The submenu is then redrawn at the correct position.

Dirk (rptq) wrote :

Bug #329164 seems to be talking about the same thing

moonbeam (rcryderman) wrote :

Resolved with the current cairo-menu in rewrite. Though I do _not_ have themable menus implemented yet, since I'm building on the existing GtkMenu and GtkMenuItems this type of issue should not popup again.

Changed in awn-extras:
status: Confirmed → In Progress
milestone: none → 0.4.0
moonbeam (rcryderman) on 2010-04-05
Changed in awn-extras:
status: In Progress → Fix Committed
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers