IndexError when Volume Control cannot find any devices

Bug #365792 reported by c4d0rn4 on 2009-04-24
4
Affects Status Importance Assigned to Milestone
Awn Extras
Low
onox

Bug Description

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/awn/extras/awnlib.py", line 1513, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 75, in __init__
    self.setup_context_menu()
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 160, in setup_context_menu
    self.load_device_pref(prefs)
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 206, in load_device_pref
    self.applet.settings["device"] = self.backend.get_default_device()
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 414, in get_default_device
    return self.get_device_labels()[0]
IndexError: list index out of range

Related branches

Mark Lee (malept) wrote :

Per the bug reporting guidelines on the page where you reported the bug, we need the following information:
* Distribution name and version
* Method of installing Awn and Awn Extras (if via repository, which repository? If from source, via tarball or bzr?)
* Awn version (if from bzr, which branch and which revision?)

Any information about your sound card and/or sound setup would probably be useful here as well.

tags: added: applet traceback volume-control
Changed in awn-extras:
assignee: nobody → onox (onox)
onox (onox) wrote :

I'm sure this is trunk. @c4d0rn4: is it that you have no sound cards?

Changed in awn-extras:
importance: Undecided → Low
milestone: none → 0.4.0
status: New → Confirmed

Hello there, to be honest I reported the bug, because the program asked me to do it. At the moment is working flawless, a normal boot did the trick.

BTW, if someone want to know:
OS: Jaunty RC Ubuntu

awn version: 0.3.3-trunk-bzr561-jaunty1-1

Source:
deb http://ppa.launchpad.net/awn-testing/ppa/ubuntu jaunty main
deb-src http://ppa.launchpad.net/awn-testing/ppa/ubuntu jaunty main

Hardware:
mother: asus m2n68-am

The error appeared after booting on text-only mode, and then I started X. For booting in text mode I disabled gdm on rc2.d. I've a hunch that disabeling gdm on rc2.d is not the right way, but I was testing something.

I hope to haven't annoyed anybody. Truly I sent the bug report because the program asked me to do it. And also, excuse me for my English; my writing skills is seriously rusty.

________________________________
From: c4d0rn4 <email address hidden>
To: <email address hidden>
Sent: Thursday, April 23, 2009 9:31:05 PM
Subject: [Bug 365792] [NEW] Volume control Awn - list index out of range

Public bug reported:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/awn/extras/awnlib.py", line 1513, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 75, in __init__
    self.setup_context_menu()
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 160, in setup_context_menu
    self.load_device_pref(prefs)
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 206, in load_device_pref
    self.applet.settings["device"] = self.backend.get_default_device()
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 414, in get_default_device
    return self.get_device_labels()[0]
IndexError: list index out of range

** Affects: awn-extras
     Importance: Undecided
         Status: New

--
Volume control Awn - list index out of range
https://bugs.launchpad.net/bugs/365792
You received this bug notification because you are a direct subscriber
of the bug.

Status in Awn Extras: New

Bug description:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/awn/extras/awnlib.py", line 1513, in init_start
    applet_class(applet)
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 75, in __init__
    self.setup_context_menu()
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 160, in setup_context_menu
    self.load_device_pref(prefs)
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 206, in load_device_pref
    self.applet.settings["device"] = self.backend.get_default_device()
  File "/usr/share/avant-window-navigator/applets/volume-control/volume-control.py", line 414, in get_default_device
    return self.get_device_labels()[0]
IndexError: list index out of range

Since you say that the bug does not occur anymore without any modifications to the applet, I'm marking this as "Invalid". If this occurs again, please change the status back to "New", with the details of what you were doing when the bug occurred.

Changed in awn-extras:
status: Confirmed → Invalid
onox (onox) wrote :

I'm reopening this bug because volume control assumes there's always at least one sound device. Instead, if zero devices are found, then it should display (at least) an error icon.

Changed in awn-extras:
status: Invalid → Triaged
summary: - Volume control Awn - list index out of range
+ IndexError when Volume Control cannot find any devices
onox (onox) wrote :

Fixed in revision 1264 of extras-trunk-rewrite-and-random-breakage branch. Testing PPA's will be available somewhere in July.

Changed in awn-extras:
status: Triaged → Fix Committed
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
c4d0rn4 (c4d0rn4.) wrote :
c4d0rn4 (c4d0rn4.) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers