All AWN Applets Dead After Update (Jaunty 64-bit)

Bug #355405 reported by vaughn on 2009-04-05
6
Affects Status Importance Assigned to Milestone
Awn Extras
High
Unassigned

Bug Description

After Synaptic updated AWN Trunk, Linux Kernel and a bunch of other stuff (see attached; scroll past AWN output), all of my AWN applets are dead; the trash applet is still there, but it doesn't work (and hasn't ever for my in Jaunty). Running AWN from the terminal, it's throwing tons of errors regarding the applets (see attached).

Distribution Name & Version: Ubuntu Jaunty Jackalope 64-bit (Gnome)
AWN & Extras installed via PPA Launchpad (Awn testing)
AWN Version: 0.3.3-trunk-bzr561-jaunty1-1
Window Manager: Stock Compiz with Extra Effects enabled
Video Card: Nvidia GeForce 7600GS with 180.44 driver
It's a crash (I think)

vaughn (vaughngrisham) wrote :
Mark Lee (malept) wrote :

So, in addition to cairo-clock, weather, volume-control, to-do, calendar, and quit-applet not working, affinity, filebrowser, cairo-menu, standalone-launcher, and awnterm also don't work? That's quite impressive.

For the first set of applets, it appears that it can't find one of the python modules that is installed by awn-extras-applets-trunk. I'd guess that Ubuntu broke something in Python-land (again).

As to the second set of applets, I have no clue whatsoever. Perhaps someone else can shed some light?

Changed in awn-extras:
status: New → Incomplete
vaughn (vaughngrisham) wrote :

I should have added that I tried reinstalling everything AWN related to no avail.

Re: "That's quite impressive."

Yes, perhaps I should have titled my bug report, "Jaunty Beta makes AWN go boom, then splat."

moonbeam (rcryderman) wrote :

This shouldn't matter but just due to the oddness of this I'm going to suggest running

sudo ldconfig

in a terminal. then try starting awn again.

It might just simply need a rebuild? I've been running Jaunty with awn and awn-extras built from trunk with no issues. All those applets listed above seem to work for me.

Although maybe unrelated, rebuilding from source today, I got this error on configure:

configure: error: python module gdata required (python-vobject)

I installed python-vobject and every thing worked fine. A brand new dependency or a change in which ubuntu package offers the module?

Mark Lee (malept) wrote :

Andrew: it's a new dependency, which is reflected in the debian/control file. I just typoed on the error message, thanks for pointing it out.

I'll attempt to roll a new awn-extras-applets-trunk build shortly.

Mark Lee (malept) wrote :

Apparently the new trunk build took, and it should be available.

vaughn: can you see if this awn-extras build is any different from the previous one?

vaughn (vaughngrisham) wrote :

Mark,

From Synaptic, awn-extras-applets-trunk is version 0.3.3~bzr1150-1.9.04

Moonbeam,

That command did not affect the problem.

vaughn (vaughngrisham) wrote :

Mark,

An update for awn-extras-applets-trunk just appeared in Synaptic. I installed, but the problem is unchanged.

Chris Johnston (cjohnston) wrote :

I have the same problem on 32bit..

Chris Johnston (cjohnston) wrote :

I believe that the problem has been located. It has to do with Ubuntu changing the python package installation directory. The devs are aware of the problem, and will hopefully be able to have a fix soon.

techno-mole (techno-mole) wrote :

i have been experiencing a similar issue (maybe the same) with the trunk version of awn and the beta of jaunty (9.04)

these are the applets that are crashing for me -

animal farm applet
arss applet
battery applet (im using a desktop system)
cairo clock applet
clock/calender applet
comics applet
cpu frequency monitor applet
desktop manager applet
digg applet
digital clock applet
file browser launcher applet
mail applet
media control applet
all the media control applets (eg - play applet, back applet and next track applet)
mount applet
pandora radio applet
pynot applet
pynot rgba applet
quit/log out applet
show desktop applet
stand alone task manager applet
thinkhdaps applet
to do list applet
tomboy applet
volume control applet
weather applet

here is the message i get in terminal when i try adding any of the above applets to the bar -

Creating new applet :/usr/share/avant-window-navigator/applets/weather.desktop uid:1238936983
Traceback (most recent call last):
File "/usr/share/avant-window-navigator/applets/weather/weather.py", line 39, in <module>
from awn.extras import awnlib
ImportError: No module named extras

this message is the same for all the above applets as well.

cheers

Julien Lavergne (gilir) wrote :

Fix commited on r1154 for awn-extras.

Mark Lee (malept) wrote :

cJ has confirmed on IRC that gilir's changes have fixed the problem.

Changed in awn-extras:
importance: Undecided → High
milestone: none → 0.3.2.2
status: Incomplete → Fix Committed
techno-mole (techno-mole) wrote :

daft question, but is the fix available yet ?

cheers

vaughn (vaughngrisham) wrote :

techno-mole, it is indeed available through Synaptic. All of the applets except Trash are working again, though I had to reboot. Hopefully Trash will get fixed soon.

techno-mole (techno-mole) wrote :

me again, okay just to make sure, but if its the version of the awn applets thats marked in synaptic as - awn-extra-applets-trunk, latest version - 0.3.3~bzr1151-1.9.04 then it doesnt work for me.

is it perhaps because im running 32 bit jaunty ?

cheers

Mark Lee (malept) wrote :

The latest version for awn-extras-applets-trunk (Jaunty, all arches) is currently 0.3.3~bzr1156-1.9.04. According to the PPA page, they all built successfully.

techno-mole (techno-mole) wrote :

the applets are working now.

ive been having some issues with synaptic, for some reason it doesnt always show packages and such like, when i first added the jaunty ppa repo it didnt show up in synaptic, all i had was the awn version thats included already.

i dont know why but i keep having to rebuild the index every so often other wise nothing shows up, even if i do apt-get install in terminal to install stuff, still doesnt show up in synaptic.

cheers.

vaughn (vaughngrisham) wrote :

techno-mole, search Synaptic for both avant-window-navigator and awn. You should find everything that way.

Mark Lee (malept) wrote :

Fix released in Awn Extras 0.3.2.2.

Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments