Cairo menu opens submenu in strange places sometimes

Bug #329164 reported by Eugene on 2009-02-13
4
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
moonbeam

Bug Description

Hi!
Sometimes Cairo menu opens submenu in strange places - far from root menu or just above it.
It reproduces not very often. Really I don't know accurate conditions to repeat this effect.

Please look at screenshots.
Version: 0.3.3-trunk installed from PPA as it's written in manual on this site.
OS: Ubuntu 8.10 Intrepid Iron
Locale: Russian UTF-8
Resolution: 1280x800 px (laptop)

Related branches

Eugene (lisitsky) wrote :
Eugene (lisitsky) wrote :
Eugene (lisitsky) wrote :

That do you think of using standard Gnome menu? May be it can solve some problems?

Eugene (lisitsky) wrote :

> Does it correct its placement next time to you navigate to the submenu (without restarting the applet) ?
Sometimes. I've just seen overlay effect 2 times, and after several minutes all is ok.

> What window manager is being used?
Gnome 2.24.1, installed from Ubuntu repo. All software is updated automatically with package manager.

Mark Lee (malept) wrote :

Per the instructions on the bug reporting page, this should have been
filed in the Awn Extras project, as this is an applet specific bug.

Moving to awn-extras.

Changed in awn:
assignee: nobody → rcryderman
moonbeam (rcryderman) on 2009-02-24
Changed in awn-extras:
importance: Undecided → Medium
status: New → In Progress
Eugene (lisitsky) wrote :

Hi!

I've just installed rev 1110. Looks like problem has gone!

Thank you.

moonbeam (rcryderman) on 2009-04-05
Changed in awn-extras:
status: In Progress → Fix Committed
moonbeam (rcryderman) on 2010-04-05
Changed in awn-extras:
milestone: none → 0.4.0
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers