tomboy applet must be removed/added every time an update is done

Bug #252752 reported by Wes Garner on 2008-07-29
6
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
Michal Hruby

Bug Description

Every time an update is done - after restart, tomboy applet just shows gray vertical line
Tomboy does show in upper status bar
Once removed and added back, applet works as it should

AWN 0.3.1-bzr
http://ppa.launchpad.net/awn-testing/ubuntu
Using Compiz/Emerald
intel i815

Mark Lee (malept) wrote :

Does this only occur with the tomboy applet?

What is the terminal output when you run avant-window-navigator from the command line?

Changed in awn:
status: New → Incomplete
nasrin (sba001) wrote :

Same behaviour here with tomboy applet.
AWN 0.3.1 from http://ppa.launchpad.net/awn-testing/ubuntu hardy main
when I start awn from terminal, tomboy applet appears at once. I get some output (see below) but thats more related to the battery applet I think. (Added battery applet but it doesn't appear at all, not even a vertical line).

output:
(awn-applets-migration.py:7070): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `AwnConfigClient'
Screen is composited.
LOADED : /home/sunnje/.config/awn/launchers/awn_launcher-2.desktop
LOADED : /home/sunnje/.config/awn/launchers/awn_launcher-1.desktop
APPLET : /usr/share/avant-window-navigator/applets/taskman.desktop
APPLET : /usr/share/avant-window-navigator/applets/showdesktop.desktop
APPLET : /usr/share/avant-window-navigator/applets/awnterm.desktop
APPLET : /usr/share/avant-window-navigator/applets/digitalClock.desktop
APPLET : /usr/share/avant-window-navigator/applets/to-do.desktop
APPLET : /usr/share/avant-window-navigator/applets/tomboy-applet.desktop
APPLET : /usr/share/avant-window-navigator/applets/awnnotificationdaemon.desktop
APPLET : /usr/share/avant-window-navigator/applets/places.desktop
APPLET : /usr/share/avant-window-navigator/applets/main-menu.desktop
APPLET : /usr/share/avant-window-navigator/applets/trasher.desktop
APPLET : /usr/share/avant-window-navigator/applets/battery-applet.desktop
APPLET : /usr/share/avant-window-navigator/applets/quit-applet.desktop

** (awn-applet-activation:7086): WARNING **: Places: XDG_DESKTOP_DIR is not set... defaulting to "~/Desktop"

The following is an informational message only:
notification-daemon: no process killed
First attempt failed: The following is an informational message only:
notification-daemon: no process killed
Traceback (most recent call last):
  File "/usr/share/avant-window-navigator/applets/battery-applet/battery-applet.py", line 419, in <module>
    BatteryStatusApplet(applet)
  File "/usr/share/avant-window-navigator/applets/battery-applet/battery-applet.py", line 74, in __init__
    self.__message_handler = MessageHandler(self)
  File "/usr/share/avant-window-navigator/applets/battery-applet/messagehandler.py", line 29, in __init__
    self.set_next(InvisibleMessageState)
  File "/usr/share/avant-window-navigator/applets/battery-applet/messagehandler.py", line 32, in set_next
    self.__state = state(self)
  File "/usr/share/avant-window-navigator/applets/battery-applet/messagehandler.py", line 42, in __init__
    self.handler.message.close()
gobject.GError: 0 is not a valid notification ID

Mark Lee (malept) wrote :

If it *only* happens with the tomboy applet, I'm inclined to think it's an applet specific issue.

And yes, that error message is related to the battery applet.
nasrin: is tomboy running when the applet is loaded?

Wes Garner (wesgarner) wrote :

Doing a reinstall of AWN and TomBoy seems to have fixed itself
Mine has been working perfectly for a few weeks on Intrepid using the AWN Testing repo

Also, note: TomBoy is opened up automatically during AWN's launch

nasrin (sba001) wrote :

Only happens with the tomboy applet, at least out of the applets I've installed. Tomboy is running when the applet is loaded, yes.

Mark Lee (malept) wrote :

So from what I can tell, this behavior doesn't occur with Intrepid, but it does occur with Hardy. Given that the Awn/Awn Extras packages in the PPA are generated from the exact same source, regardless of distro version, I think that this is a problem lower in the stack.

Mark Lee (malept) wrote :

I really don't know what to do about this bug, as it only occurs on Hardy.

tags: added: applet tomboy
Changed in awn-extras:
importance: Undecided → Medium
status: Incomplete → Confirmed
Michal Hruby (mhr3) on 2010-04-14
Changed in awn-extras:
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 0.4.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers