Cairo Main Menu doesn't update the menus when software is installed

Bug #221836 reported by santins on 2008-04-25
2
Affects Status Importance Assigned to Milestone
Awn Extras
Undecided
moonbeam

Bug Description

When new software is installed the 'cairo main menu' doesn't show the new icon for that software until it is restarted.

My operating system is Ubuntu 8.04 with Gnome.

I'm using those repositories for the installation of AWN:
  deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main
  deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main (Source code)

moonbeam (rcryderman) wrote :

This is deliberate design decision. It is related to the fact that cairo creates and caches the menu item pixmaps on startup. At some point in time I may revisit the code and look into dynamically updating in this case. I'll leave the status as new till I give some consideration to when that may happen.

Thanks for supporting awn.

moonbeam (rcryderman) on 2009-02-07
Changed in awn-extras:
assignee: nobody → rcryderman
milestone: none → 0.4.0
status: New → Confirmed
Mark Lee (malept) on 2009-04-03
tags: added: cairo-menu
removed: cairo-main-menu
moonbeam (rcryderman) on 2010-04-05
Changed in awn-extras:
status: Confirmed → Fix Committed
Mark Lee (malept) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
summary: - cairo main menu doesn't update the menus when software is installed
+ Cairo main menu doesn't update the menus when software is installed
summary: - Cairo main menu doesn't update the menus when software is installed
+ Cairo Main Menu doesn't update the menus when software is installed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers