Entering 'exit' in terminal applet breaks it

Bug #195151 reported by Michael Rooney on 2008-02-24
24
Affects Status Importance Assigned to Milestone
Awn Extras
Low
Natan Yellin

Bug Description

Normally entering the 'exit' command into a terminal will close the terminal window. However this behavior doesn't particularly make sense for this applet since it is designed to always be in the bar. However entering this command seems to break the ties to the terminal so maybe it needs to ignore this command somehow if possible, printing a message when it is entered.

Michael Rooney (mrooney) wrote :

I mentioned this in #193889 and it looks like some initial work to address it was checked in, but that bug was marked as fixed so I figure this deserves is own.

Changed in awn-extras:
assignee: nobody → aantny
importance: Undecided → Low
status: New → Confirmed
J. H. Cho (hyun5) wrote :

I have made a little patch to fix this problem by simply forking new vte when it exits

J. H. Cho (hyun5) wrote :

tried on awn-extras-co, r895
when exit command is executed, it will fork new terminal and hide terminal

Natan Yellin (aantny) wrote :

Thanks for the patch!

Committed in revision 897.

Changed in awn-extras:
status: Confirmed → Fix Committed
J. H. Cho (hyun5) wrote :

I hope it helped.

Also line 58, 59 of applet.c:
        // This doesn't work... Fix it in a future release.
        //g_signal_connect (G_OBJECT (applet->terminal), "child-exited", G_CALLBACK (exited_cb), NULL);

should be removed.

Natan Yellin (aantny) wrote :

Thanks for catching that.

It's removed in revision 905.

Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers