leaving vim insert mode impossible from terminal plugin

Bug #178784 reported by revel on 2007-12-26
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Low
Michal Hruby

Bug Description

It seems that pressing ESC always hides terminal window
is there a way to pass ESC to program inside terminal? (vim for instance)

Mark Hayes (hayesm) wrote :

CTRL-C will get you out of insert mode.

revel (revel) wrote :

it works, thank you :-)
however, sending ESC keycode somehow would still be nice and useful
for programs like screen or midnight commander (ie when F1-F12 function keys dont work)
just my 2 cents
best regards and thank you for your work
happy new year

moonbeam (rcryderman) on 2008-02-10
Changed in awn-extras:
assignee: nobody → aantny
status: New → Confirmed
turururu (dariom-hotmail) wrote :

in my spanish keyboard:
Escape= Ctrl+o
( vi vim awn terminal visual mode )

Michal Hruby (mhr3) wrote :

As a side note, this shouldn't be a problem in the rewrite, since you can disable the dialog hiding on Esc with a property of AwnDialog.

Michal Hruby (mhr3) on 2010-04-14
Changed in awn-extras:
assignee: Natan Yellin (aantny) → Michal Hruby (mhr3)
importance: Undecided → Low
milestone: none → 0.4.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers