[awn-notification-deamon] Stacking notification need improvement

Bug #176040 reported by Guillaume Beland on 2007-12-13
2
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
moonbeam

Bug Description

successive notification go out of the screen when notificaition is located in the upper side of the screen.

How to reproduce:
1) set honour_client_xy to false
2) set override_x to 1300
3) set override_y to 33
4) wait for notification

In fact the newest notification always appear at x = 1300, y = 33 and the previous notification is stacked at the top. the wished behavior would be to place the newest notification right at the bottom of the previous notification. (or at the top if the overide_y is located in the lower part of the screen.)

I also tried what i think is the default setting:
1) set honour_client_xy to true
2) set override_x to -1
3) set override_y to -1

In that case the notification to always appear above the previous one ( like standard notification, which is not bad but not perfect)

here's a screenshot that explain everything:
http://pix.nofrag.com/1/4/4/5938187c5ffdc207294e005349595.html

For me it's not a big deal and i can easily live with it. so no need to hurry

Guillaume

moonbeam (rcryderman) on 2007-12-13
Changed in awn-extras:
assignee: nobody → rcryderman
importance: Undecided → Medium
status: New → Confirmed

I investigated the problem a little and I found my problem. The problem is with gdk/glib, maybe only with my gdk/glib version/build I didn't had the chance to test it on other system.

In stack.c at line 165, there's a call for gdk_screen_get_default() which return null, so gdk_screen_get_height() return 0 so stacking_direction can't be set to -1.

I tried gdk_screen_height with no positive result. I don't know if there's other way to get the screen resolution easily, I didn't investigate, but for the moment I've set stacking_direction to -1 manually and it work nicely.

moonbeam (rcryderman) wrote :

Thanks.

I'll investigate that. I haven't forgotten about this bug... just trying to do to many things with limited time :-)

moonbeam (rcryderman) wrote :

"In stack.c at line 165, there's a call for gdk_screen_get_default() which return null, so gdk_screen_get_height() return 0 so stacking_direction can't be set to -1."

Did a bit of testing here... and I'm not getting this behaviour. gdk_screen_get_height (gdk_screen_get_default() ) is returning the proper value. But what I will do is look into the docs and try an alternate way to get the gdk_screen if the gdk_screen_get_default() returns NULL.

moonbeam (rcryderman) wrote :

 Guillaume,

Could you verify if DISPLAY is set and if so what it is set to?

moonbeam (rcryderman) wrote :

I believe rev 336 to trunk may resolve this issue.

Changed in awn-extras:
status: Confirmed → Triaged

Indeed it now work flawlessly with rev 336 . Thank you and sorry for not answering your previous question, I was kind of busy.

moonbeam (rcryderman) on 2008-02-22
Changed in awn-extras:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers